Cow Contest POJ - 3660 (floyd求传递闭包)

Cow Contest

POJ - 3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cowA has a greater skill level than cow B (1 ≤ AN; 1 ≤BN; AB), then cow A will always beat cowB.

Farmer John is trying to rank the cows by skill level. Given a list the results ofM (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

题意:

题目给出了m对关系,求有多少个点的顺序关系是确定的。

思路:只要是这个点个其他所有点的关系是确定点,那么这个点的次序就是确定了,进一步简化,也就是看这个点是否和其他所有点有关系(边)不用管边的方向,因为不管什么方向,只要右边就可以确定一种关系,所以这个题就可以用floyd求传递闭包来做

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n,m;
int G[120][120];
int main(){
    int i,j;
    cin >> n >> m;
    memset(G,0,sizeof(G));
    for(i = 1; i <= m; i++){
        int u,v;
        cin >> u >> v;
        G[u][v] = 1;
    }
    int k;
    //floyd求传递闭包的核心算法
    for(k = 1; k <= n; k++){
        for(i = 1; i <= n; i++){
            for(j = 1; j <= n; j++){
                G[i][j] = G[i][j] || (G[i][k] && G[k][j]);
            }
        }
    }
    //把每个点都判断一下,看是否可以确定关系
    int ans = 0;
    for(i = 1; i <= n; i++){
        for(j = 1; j <= n; j++){
            if(i == j)continue;
            if(!G[i][j] && !G[j][i])
                break;
        }
        if(j > n)
            ans++;
    }
    cout << ans << endl;
    return 0;
}





























































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值