(有坑可复习)poj 1083 Moving Tables 模拟/贪心/技巧性质

Moving Tables
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25839 Accepted: 8600

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30


题目大意:

四百个房间,两排,每排两百个。现要在房间间搬桌子,任意房间间搬桌子的时间都是十分钟。

且每个房间只会要么搬出要么搬进,具有重叠部分的两次搬运不可同时进行(闭区间)。

要求最小搬运次数。


解题思路:

法一, 可以先按照左端点升序排序,每次扫一遍,将所有可以同时进行的搬运一次处理完(这里是用结构体内的used标记),最后计算总次数即可。

法二,直接找出被区间覆盖最多的那个点的覆盖次数就是答案 - -这个方法没做

本题需要注意两个问题:坑~!!!!

第一,一号房和二号房是不能同时搬运的,所以可以在输入时将奇数变为偶数。

第二,要注意给的数据不一定是前小后大,所以如果前大后小就需要交换一下



下面是ac代码:

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <memory>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <numeric>
#include <functional>
#define maxn 205
#define mod 100007

using namespace std;
struct M{
    bool used;
    int l;
    int r;
    M(){
        used=false;
    }
};

bool comp(const M &a,const M &b)
{
    return a.l<b.l;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        M mov[maxn];
        scanf("%d",&n);
        for(int i=0;i<n;i+=1){
            int a,b;
            scanf("%d %d",&a,&b);
            if(a>b) swap(a,b);
            if(a%2!=0) a+=1;
            if(b%2!=0) b+=1;
            mov[i].l=a;
            mov[i].r=b;
        }
        sort(mov,mov+n,comp);

        /*for(int i=0;i<n;i+=1){
            printf("%d %d\n",mov[i].l,mov[i].r);

        }*/

        int countt=0;
        bool flag=true;
        while(flag){
            int next=-1;
            flag=false;
            for(int i=0;i<n;i+=1){
                if(!(mov[i].used)&&next<mov[i].l){
                    next=mov[i].r;
                    mov[i].used=true;
                    flag=true;
                }
            }
            countt+=1;
        }

        printf("%d\n",(countt-1)*10);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值