Waiting ten thousand years for Love

最后一道搜索题,关键是划分状态。分析这道题:

如果以(x,y)为状态,无法唯一确定状态。因为(‘.’ Indicate the road that Yifenfei can walk on it, or fly over it.)

所以必须要(x,y,p)为状态区分。

本题采用bfs+优先队列

It was ten thousand years, after Demon Lemon caught Yifenfei’s love. In order to revenge and save his love, Yifenfei have been practising sword all day long and his Kongfu skills becomes so powerful that he can kill Demon Lemon immediately. Recently, Yifenfei have found Lemon’s castle, and now he is going to kill Lemon. At the same time, hearing about the terrible news, Demon Lemon is now preparing for escaping...

Now Yifenfei has got the map of the castle.
Here are all symbols of the map:
Only one ‘Y’ Indicates the start position of Yifenfei.
Only one ‘L’ Indicates the position of Demon Lemon.
‘.’ Indicate the road that Yifenfei can walk on it, or fly over it.
‘#’ Indicate the wall that Yifenfei can not walk or flay through it.
‘@’ Indicate the trap that Yifenfei can not walk on it, but can fly over it.

Yifenfei can walk or fly to one of up, down, left or right four directions each step, walk costs him 2 seconds per step, fly costs him 1 second per step and 1 magic power. His magic power will not increased, and if his magic power is zero, he can not fly any more.

Now Yifenfei asks you for helping him kill Demon Lemon smoothly. At the same time, Demon Lemon will Leave the castle Atfer T seconds. If Yifenfei can’t kill Demon Lemon this time, he have to wait another ten thousand years.
 

Input
Lots of test cases, please process to end of file. In each test case, firstly will have four integers N, M, T, P(1 <= N, M, P <= 80, 1 <= T <= 100000), indicates the size of map N * M, the Lemon’s leaving time(after T seconds, Lemon will disappeared) and Yifenfei’s magic power. Then an N * M two-dimensional array follows indicates the map.
 

Output
For each test case, first Print a line “Case C:”, C indicates the case number. Then, if Yifenfei can kill Demon Lemon successfully, Print “Yes, Yifenfei will kill Lemon at T sec.”, T indicates the minimum seconds he must cost. Otherwise, Print ”Poor Yifenfei, he has to wait another ten thousand years.”
 

Sample Input
  
  
2 3 2 2 Y@L ### 2 3 4 1 Y@L ### 2 3 4 0 Y.L ### 2 3 3 0 Y.L ###
 

Sample Output
  
  
Case 1: Yes, Yifenfei will kill Lemon at 2 sec. Case 2: Poor Yifenfei, he has to wait another ten thousand years. Case 3: Yes, Yifenfei will kill Lemon at 4 sec. Case 4: Poor Yifenfei, he has to wait another ten thousand years.
Hint
Hint Case 1: Yifenfei cost 1 second and 1 magic-power fly to ‘@’, but he can not step on it, he must cost another 1 second and 1 magic-power fly to ‘L’ and kill Lemon immediately. Case 2: When Yifenfei Fly to ‘@’, he has no power to fly, and is killed by trap.


#include<iostream>
#include<queue>
using namespace std;
typedef struct node{
    int i;
int j;
int t;
int p;


    
}Node;
struct qcmp
 {
     bool operator() (const Node a,const Node b)
     {
         return a.t>b.t;
     }
 };
char field[81][81];


int N,M,T,P;
bool isvisit[81][81][81];
bool cross(int a,int b)
{
   if(a>=0&&a<N&&b>=0&&b<M&&field[a][b]!='#')
   {
      return true;
   }
   return false;


}
int dir[][2]={{0,1},{1,0},{-1,0},{0,-1}};
 
void bfs(int a,int b)
{
    bool isfind=false;
int count=0;
Node start={a,b,0,P};
isvisit[a][b][P]=true;
priority_queue<Node,vector<Node>,qcmp> myqueue;
myqueue.push(start);
while(!myqueue.empty())
{
  Node pre=myqueue.top();
  myqueue.pop();
  if(pre.t<=T&&field[pre.i][pre.j]=='L')
  {
    isfind=true;
count=pre.t;

break; 
  }
  if(pre.t>T)
  break;
  
  for(int i=0;i<4;i++)
  {
  int curi=pre.i+dir[i][0];
  int curj=pre.j+dir[i][1];
  int curp=pre.p;
  int curt=pre.t;
     if(cross(curi,curj)&&pre.t<T)
 {
    if(field[pre.i][pre.j]!='@'&&field[curi][curj]!='@'&&!isvisit[curi][curj][curp])
{
   
  isvisit[curi][curj][curp]=true;
  int tempt=curt;
  tempt+=2;
  Node cur1={curi,curj,tempt,curp};
  myqueue.push(cur1);
 

if(!isvisit[curi][curj][curp-1]&&curp>0)
{
 isvisit[curi][curj][curp-1]=true;
 curt+=1;
 curp-=1;
 Node cur2={curi,curj,curt,curp};
 myqueue.push(cur2);
 
}
 
 }
  
  
  
  }
  
     
  }
     

  
 






   if(isfind)
   {
    printf("Yes, Yifenfei will kill Lemon at %d sec.\n",count);  
   }
   else
   {
     printf("Poor Yifenfei, he has to wait another ten thousand years.\n");
   }


}
int main()
{
//freopen("in.txt","r",stdin);
int icase=0;
int i,j;
while(scanf("%d%d%d%d",&N,&M,&T,&P)!=EOF)
{
int s1,s2;
  for(i=0;i<N;i++)
  {
    for(j=0;j<M;j++)
{
   cin>>field[i][j];
if(field[i][j]=='Y')
{
 s1=i;
 s2=j;

}

}
  }
  memset(isvisit,false,sizeof(isvisit));
 
       cout<<"Case "<<++icase<<":"<<endl;
  bfs(s1,s2);



}
  return 0;
}

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 、5资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值