ZOJ3203 Light Bulb[三分/推公式]

Light Bulb
Time Limit:1000MS     Memory Limit:32768KB

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places.

Sample Input

     
     

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output
     
     

1.000
0.750
4.000
 
  
 
 
 

题意:

首先给出T组数据,每组给出灯离地面高度H,人的身高h,灯跟墙的距离D,人站在不同位置,影子的长度都不一样,求出最长的影子的长度。

题解:

计算出来的这条式子,可以直接进行三分,求出极值点,但是同样,我们可以通过这条公式用O(1)的方法求出来

三分写法:

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const double esp=1e-8;
double H,h,D;
double cal(double x)
{
	return D-x+H-(H-h)*D/x;
}
double three_devide(double l,double r)
{
	double left=l,right=r,mid,midmid;
	while (left+esp<right)
	{
		mid=(right+left)/2;
		midmid=(right+mid)/2;
		if (cal(mid)>=cal(midmid))
			right=midmid;
		else
			left=mid;
	}
	return cal(right);
}
int main()
{
    int T;
	scanf("%d",&T);
	while (T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        double l=D-h*D/H,r=D;
        double ans=three_devide(D-h*D/H,r);
        printf("%.3f\n",ans);
    }
	return 0;
}

推公式写法:

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const double esp=1e-8;
double H,h,D;
int main()
{
	int T;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		double mx=D-h*D/H;
		if (D>=sqrt((H-h)*D) && mx<=sqrt((H-h)*D))
            mx=D+H-2*sqrt((H-h)*D);
		else if (sqrt((H-h)*D)<mx)
            mx=h*D/H;
        else
            mx=h;
		printf("%.3lf\n",mx);
	}
	return 0;
}

[作为还是渣渣的我,今年第一次给新生讲座讲二分三分,就来写写了,好紧张,导致自己讲的特别糟糕,感觉效果也不怎么好,不过,还是第一次这样呢,希望还能继续这条路.要开始继续努力的写题了,为了不让自己留下遗憾!]


  • 4
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 8
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值