POJ 3253Fence Repair(哈夫曼&优先队列)

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21545 Accepted: 6875

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题目意思是给你一根很长的木头,把他切成n块,每块的长度为a[i],切长度为x的木块需要花费x元,问最小花费。如上所示,很显然初始长度为8+5+8=21,那么先把它切成16和5的花费21元,然后再切16切成8+8需要花费16元,所以总共花费为37元。但是如果先切成8和13就会花费21+13=34元。利用哈夫曼思想,每次找两个最小的然后变成一个数插入到数组中去。开始使用的是模拟排序,但是时间500ms左右。

后面使用优先队列做的,时间瞬间降到了16MS,优先队列定义为priority_queue <ll,vector<ll>,greater<ll> > mq;  使用less是递减的,greater递增。

模拟AC代码:
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[20002];

int main()
{
    int n,i;
    long long res,tmp;
    while (cin >> n)
    {
        for (i = 0; i < n; i++)
            scanf("%I64d",&a[i]);

        int t = 0;

        res=0;
        sort(a,a+n);

        while (t < n)
        {
            tmp = a[t] + a[t+1];
            if(t==n-2)
            {
                res += tmp;
                break;
            }

            for(i=t+2;i<n;i++)
            {
                if(tmp < a[i])      //插入
                {
                    a[i-1] = tmp;
                    break;
                }
                else
                    a[i-1] = a[i];
            }
            if(i==n)
                a[i-1] = tmp;
            t++;
            res += tmp;
        }
        cout << res << endl;
    }
    return 0;
}

/*
3
8
5
8
*/

//380K  454MS


使用STL priority_queue代码:
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<queue>
typedef long long ll;
using namespace std;

priority_queue <ll,vector<ll>,greater<ll> > mq;

int main()
{
    int n,i;
    ll res,tmp,p1,p2;
    while(cin>>n)
    {
        res=0;
        while(!mq.empty())   //先清空
            mq.pop();
        while(n--)
        {
            scanf("%lld",&tmp);
            mq.push(tmp);
        }

        while(mq.size()>1)
        {
            p1=mq.top(); mq.pop();
            p2=mq.top(); mq.pop();
            res+=p1+p2;
            mq.push(p1+p2);
        }
        cout<<res<<endl;
    }
    return 0;
}

//508K 16MS


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值