uva306 - Cipher 置换群

Cipher 

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, tex2html_wrap_inline27 , greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position tex2html_wrap_inline33 , where tex2html_wrap_inline33 is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number tex2html_wrap_inline51 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE     

  给你一种置换方法,a[i]=j就是经过一次置换,第i个位置的元素到j位置去了。问经过n次置换以后的字符串。

  如果暴力会超时的,但是n只有200。。因为置换是不重复的,所以最多经过n次又换成了他自己。。也就是它有一个周期,周期最大是n。

  比如第一个样例 1-4-7-1。。。2-5-2。。。3-3。。。6-8-6。。。9-10-9。。(147)(25)(3)(68)(9,10)这么循环,所以只要找到每个位置的周期就很快了不会超时。


#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cctype>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int N,M;
char str[210],ans[210],code[210];
int t[210],a[210];
void init(){
    int i,j,p;
    memset(t,0,sizeof(t));
    for(i=1;i<=N;i++){
        p=a[i];
        t[i]=1;
        while(p!=i){
            p=a[p];
            t[i]++;
        }
    }
}
void solve(){
    memset(ans,' ',sizeof(ans));
    int i,j;
    for(i=1;str[i];i++) ans[i]=str[i];
    for(i=1;i<=N;i++){
        int n=M%t[i],p=i;
        for(j=0;j<n;j++) p=a[p];
        code[p]=ans[i];
    }
    for(i=1;i<=N;i++) printf("%c",code[i]);
    puts("");
}
int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d",&N),N){
        int i;
        for(i=1;i<=N;i++) scanf("%d",&a[i]);
        init();
        while(scanf("%d",&M),M){
            gets(str);
            solve();
        }
        puts("");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值