hdu5009 Paint Pearls 西安网络赛C题

Paint Pearls

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2018    Accepted Submission(s): 662


Problem Description
Lee has a string of n pearls. In the beginning, all the pearls have no color. He plans to color the pearls to make it more fascinating. He drew his ideal pattern of the string on a paper and asks for your help.

In each operation, he selects some continuous pearls and all these pearls will be painted to their target colors. When he paints a string which has k different target colors, Lee will cost k 2 points.

Now, Lee wants to cost as few as possible to get his ideal string. You should tell him the minimal cost.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains an integer n(1 ≤ n ≤ 5×10 4), indicating the number of pearls. The second line contains a 1,a 2,...,a n (1 ≤ a i ≤ 10 9) indicating the target color of each pearl.
 

Output
For each test case, output the minimal cost in a line.
 

Sample Input
  
  
3 1 3 3 10 3 4 2 4 4 2 4 3 2 2
 

Sample Output
  
  
2 7

  对一段区间的花费是这个区间不同数个数的平方,求整个区间的最小花费。

  第一眼看上去是很简单的dp。。但是卡时间。。。

  有一种类似链表的做法,在扫一遍的过程中记录每种颜色最后一次出现的位置,链表直接跳到出现下一种没出现过颜色的位置,不用一个一个找。具体做法是加入当前颜色c,若c上次出现的位置是p[c],那么把l[p[c]]和r[p[c]]连接,也就是说跳过p[c]。更新某个点dp的时候,就沿着左链表的路径更新,每走一步都多了一种颜色。

  因为前i个数最多花费是i,所以如果不同颜色种数cnt的平方大于i了就不用再继续往下更新了。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
#define INF 0x3f3f3f3f
#define eps 1e-9
#define MAXN 50010
#define MAXM 60
#define MAXNODE 105
#define MOD 100000
#define SIGMA_SIZE 4
typedef long long LL;
using namespace std;
int N,dp[MAXN],l[MAXN],r[MAXN],p[MAXN],a[MAXN];
map<int,int> mp;
int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d",&N)!=EOF){
        mp.clear();
        int n=0;
        memset(l,-1,sizeof(l));
        for(int i=0;i<=N;i++) dp[i]=i;
        for(int i=1;i<=N;i++){
            scanf("%d",&a[i]);
            if(mp[a[i]]==0) mp[a[i]]=++n;
            else{
                int tmp=p[mp[a[i]]];
                r[l[tmp]]=r[tmp];
                l[r[tmp]]=l[tmp];
            }
            if(i==1||a[i]!=a[i-1]) l[i]=i-1;
            r[i]=i+1;
            p[mp[a[i]]]=i;
            int cnt=0;
            for(int j=l[i];j!=-1;j=l[j]){
                cnt++;
                dp[i]=min(dp[i],dp[j]+cnt*cnt);
                if(cnt*cnt>i) break;
            }
        }
        printf("%d\n",dp[N]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值