【Usaco2015 Feb】【BZOJ3943】SuperBull

Description
Bessie and her friends are playing hoofball in the annual Superbull championship, and Farmer John is in charge of making the tournament as exciting as possible. A total of N (1 <= N <= 2000) teams are playing in the Superbull. Each team is assigned a distinct integer team ID in the range 1…2^30-1 to distinguish it from the other teams. The Superbull is an elimination tournament – after every game, Farmer John chooses which team to eliminate from the Superbull, and the eliminated team can no longer play in any more games. The Superbull ends when only one team remains.
Farmer John notices a very unusual property about the scores in matches! In any game, the combined score of the two teams always ends up being the bitwise exclusive OR (XOR) of the two team IDs. For example, if teams 12 and 20 were to play, then 24 points would be scored in that game, since 01100 XOR 10100 = 11000.
Farmer John believes that the more points are scored in a game, the more exciting the game is. Because of this, he wants to choose a series of games to be played such that the total number of points scored in the Superbull is maximized. Please help Farmer John organize the matches.
贝西和她的朋友们在参加一年一度的“犇”(足)球锦标赛。FJ的任务是让这场锦标赛尽可能地好看。
一共有N支球队参加这场比赛,每支球队都有一个特有的取值在1-230-1之间的整数编号(即:所有球队编号各不相同)。
“犇”锦标赛是一个淘汰赛制的比赛——每场比赛过后,FJ选择一支球队淘汰,淘汰了的球队将不能再参加比赛。
锦标赛在只有一支球队留下的时候就结束了。
FJ发现了一个神奇的规律:在任意一场比赛中,这场比赛的得分是参加比赛两队的编号的异或(Xor)值。例如:编号
为12的队伍和编号为20的队伍之间的比赛的得分是24分,因为 12(01100) Xor 20(10100) = 24(11000)。
FJ相信比赛的得分越高,比赛就越好看,因此,他希望安排一个比赛顺序,使得所有比赛的得分和最高。请帮助FJ决定比赛的顺序

Input
The first line contains the single integer N. The following N lines contain the N team IDs.
第一行包含一个整数N
接下来的N行包含N个整数,第i个整数代表第i支队伍的编号

Output
Output the maximum possible number of points that can be scored in the Superbull.
一行,一个整数,表示锦标赛的所有比赛的得分的最大值

Sample Input
4
3
6
9
10
Sample Output
37
HINT

1<=N<=2000

样例解释:

FJ先让编号为3和编号为9的队伍进行比赛,然后让编号为9的队伍赢得比赛(淘汰编号为6的队伍),现在剩下了编号为6 9 10 的队伍。

然后他让编号为6和编号为9的队伍比赛,然后让编号为6的队伍赢得比赛。现在编号为 6 10 的队伍留了下来

最后让编号为6和编号为10的队伍比赛,让编号为10的队伍赢得比赛。

所有比赛的得分和就是: (3 Xor 9)+(6 Xor 9)+(6 Xor 10)=10+15+12=37

Source

Silver

暴力建边,最大生成树
答案要longlong

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAXN 2010
using namespace std;
int n,top;
long long sum;
int a[MAXN],f[MAXN];
struct edge
{
    int u,v,w;
    bool operator <(const edge &a)const {return w>a.w;}
}e[MAXN*MAXN>>1];
int find(int x)
{
    return f[x]==x?f[x]:f[x]=find(f[x]);
}
bool Union(int a,int b)
{
    int x=find(a),y=find(b);
    if (x!=y)   {f[x]=y;return 1;}
    return 0;
}
int main()
{
    scanf("%d",&n);int tot=0;
    for (int i=1;i<=n;i++)  scanf("%d",&a[i]),f[i]=i;
    for (int i=1;i<=n;i++)
        for (int j=i+1;j<=n;j++)    e[++top].u=i,e[top].v=j,e[top].w=a[i]^a[j];
    sort(e+1,e+top+1);
    for (int i=1;i<=top;i++)
    {
        if (tot==n-1)   break;
        if (Union(e[i].u,e[i].v))   tot++,sum+=e[i].w;
    }
    printf("%lld\n",sum);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值