HDU 3849 By Recognizing These Guys, We Find Social Networks Useful 求桥及其节点


By Recognizing These Guys, We Find Social Networks Useful

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 1709    Accepted Submission(s): 451


Problem Description
Social Network is popular these days.The Network helps us know about those guys who we are following intensely and makes us keep up our pace with the trend of modern times.
But how?
By what method can we know the infomation we wanna?In some websites,maybe Renren,based on social network,we mostly get the infomation by some relations with those "popular leaders".It seems that they know every lately news and are always online.They are alway publishing breaking news and by our relations with them we are informed of "almost everything".
(Aha,"almost everything",what an impulsive society!)
Now,it's time to know what our problem is.We want to know which are the key relations make us related with other ones in the social network.
Well,what is the so-called key relation?
It means if the relation is cancelled or does not exist anymore,we will permanently lose the relations with some guys in the social network.Apparently,we don't wanna lose relations with those guys.We must know which are these key relations so that we can maintain these relations better.
We will give you a relation description map and you should find the key relations in it.
We all know that the relation bewteen two guys is mutual,because this relation description map doesn't describe the relations in twitter or google+.For example,in the situation of this problem,if I know you,you know me,too.
 

Input
The input is a relation description map.
In the first line,an integer t,represents the number of cases(t <= 5).
In the second line,an integer n,represents the number of guys(1 <= n <= 10000) and an integer m,represents the number of relations between those guys(0 <= m <= 100000).
From the second to the (m + 1)the line,in each line,there are two strings A and B(1 <= length[a],length[b] <= 15,assuming that only lowercase letters exist).
We guanrantee that in the relation description map,no one has relations with himself(herself),and there won't be identical relations(namely,if "aaa bbb" has already exists in one line,in the following lines,there won't be any more "aaa bbb" or "bbb aaa").
We won't guarantee that all these guys have relations with each other(no matter directly or indirectly),so of course,maybe there are no key relations in the relation description map.
 

Output
In the first line,output an integer n,represents the number of key relations in the relation description map.
From the second line to the (n + 1)th line,output these key relations according to the order and format of the input.
 

Sample Input
   
   
1 4 4 saerdna aswmtjdsj aswmtjdsj mabodx mabodx biribiri aswmtjdsj biribiri
 

Sample Output
   
   
1 saerdna aswmtjdsj
 

Source
 

Recommend
chenyongfu   |   We have carefully selected several similar problems for you:   3848  3851  3854  3857  3858 


题意是说给你一些名字,有的可以联系,让你求去掉一种联系之后有多少人可以两两联系。即求桥问题,首先用map建好图然后tarjan求桥的算法求出来。

#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<algorithm>
#define M 10007
using namespace std;
int n,m,num,cnt,countt;
int dfn[M],low[M],head[M],bridge[M];
struct sa
{
    int u,v,next;
} edg[M*20];
void addedge(int u,int v)
{
    edg[cnt].u=u;
    edg[cnt].v=v;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}

void tarjan(int u,int fa)
{
    dfn[u]=low[u]=++num;
    for(int i=head[u]; i!=-1; i=edg[i].next)
    {
        int v=edg[i].v;
        if(v==fa)continue;
        if(!dfn[v])
        {
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])//桥
            {
                bridge[countt++]=i;
            }
        }
        else
            low[u]=min(low[u],dfn[v]);
    }
}

int main()
{
    int t;
    char s1[20],s2[20];
    scanf("%d",&t);
    while(t--)
    {
        map<string,int>mp;
        map<int,string>mmp;
        memset(dfn,0,sizeof(dfn));
        memset(head,-1,sizeof(head));
        num=cnt=countt=0;
        int a=1;
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; i++)
        {
            scanf("%s%s",s1,s2);
            if(!mp[s1])
            {
                mp[s1]=a;
                mmp[a]=s1;
                a++;
            }
            if(!mp[s2])
            {
                mp[s2]=a;
                mmp[a]=s2;
                a++;
            }
            addedge(mp[s1],mp[s2]);
            addedge(mp[s2],mp[s1]);
        }
        tarjan(1,-1);
        int i;
        for(i=1; i<=n; i++)
            if(!dfn[i])
                break;
        if(i<=n)
        {
            printf("0\n");
            continue;
        }
        printf("%d\n",countt);
        sort(bridge,bridge+countt);
        for(int i=0; i<countt; i++)
        {
            int j=bridge[i];
            j=j/2*2;
            int x=edg[j].u;
            int y=edg[j].v;
            if(x!=y)
                printf("%s %s\n",mmp[x].c_str(),mmp[y].c_str());
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值