Pat(Advanced Level)Practice--1058(A+B in Hogwarts)

Pat1058代码

题目描述:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

AC代码:
#include<cstdio>

using namespace std;

int main(int argc,char *argv[])
{
	long long GA,GB,SA,SB,KA,KB;
	long long Gans,Sans,Kans;
	int temp;
	scanf("%lld.%lld.%lld %lld.%lld.%lld",&GA,&SA,&KA,&GB,&SB,&KB);
	temp=(KA+KB)/29;
	Kans=(KA+KB)%29;
	Sans=(SA+SB+temp)%17;
	temp=(SA+SB+temp)/17;
	Gans=temp+GA+GB;
	printf("%lld.%lld.%lld\n",Gans,Sans,Kans);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值