HDU1031——Design T-Shirt(结构体排序)

Design T-Shirt

猜猜我是谁

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8364    Accepted Submission(s): 3997


Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

 


Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

 


Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

 


Sample Input

 
 
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2

 


Sample Output

 
 
6 5 3 1 2 1
题意:
有n个人对m件衣服评价,求最高的k件衣服的编号,并且把编号从大到小输出,若评价相等,输出编号较小的。
解题思路:
用结构体保存每件衣服的总评价,并记录编号,根据评价按升序排衣服编号,取前k个编号倒叙输出(很巧妙的解决了输出编号小的问题)。
代码实现:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 100+10;
double mp[maxn];
int ans[maxn];
int n, m, k;

struct node
{
    double val=0;
    int num;
}p[maxn];

int cmp(const node a, const node b)
{
    return a.val>b.val;
}

int cmp2(const int a, const int b)
{
    return a>b;
}

int main()
{
    while( ~scanf("%d%d%d",&n,&m,&k))
    {
        memset(mp,0,sizeof(mp));
        memset(ans,0,sizeof(ans));
        for( int i=0; i<m; i++ )
            p[i].val = 0;
        for( int i=0; i<n; i++ )
        {
            for(int j=0; j<m; j++ )
            {
                double u;
                scanf("%lf",&u);
                p[j].val += u;             // 把每件衣服评价相加求总和;
                p[j].num = j+1;            // 保存衣服编号;
            }
        }
        sort(p,p+m,cmp);                   //按评价降序排序;
        //for(int i=0; i<m; i++ )
        //    cout << p[i].num <<" ";
        //cout<< endl;
        for( int i=0; i<k; i++ )
            ans[i] = p[i].num;            // 保存评价降序前k个编号;
        sort(ans,ans+m,cmp2);             // 排序编号输出;
        int i;
        for( i=0; i<k-1; i++ )
            printf("%d ",ans[i]);
        printf("%d\n",ans[i]);
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值