poj3928 树状数组应用

Ping pong
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input

1 
3 1 2 3

Sample Output

1




<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int c[20005],n;
struct node
{
	int rank,pos;
	bool operator< (const node &it)const
	{
		return rank<it.rank;
	}
}a[20005];
int sum(int i)
{
	int s=0;
	for(i;i>0;i-=i&(-i))
		s+=c[i];
	return s;
}
void add(int i,int v)
{
	for(i;i<=n;i+=i&(-i))
		c[i]+=v;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(c,0,sizeof(c));
		long long ans=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i].rank);
			a[i].pos=i;
		}
		sort(a+1,a+n+1);
		add(a[1].pos,1);
		int l_s,l_b,r_s,r_b;
		for(int i=2;i<n;i++)//看rank排第i位的这个人能不能当裁判,能当几次
		{
			l_s=sum(a[i].pos-1);//在i.pos的左边比i.rank小的人的数目

			l_b=a[i].pos-1-l_s;//在i.pos左边比i.rank大的人的数目

			r_s=sum(n)-sum(a[i].pos);//在i.pos的右边比i.rank小的人的数目

			r_b=n-a[i].pos-r_s;//在i.pos的右边比i.rank大的人的数目

			ans+=l_s*r_b+l_b*r_s;
			add(a[i].pos,1);
		}
		printf("%I64d\n",ans);
	}
}</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值