HOJ Pearls-学习DP1

Pearls

My Tags   (Edit)
  Source : ACM ICPC Northwestern European Regional 2002
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 83, Accepted : 57

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family. In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.

Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.

Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed. No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same.

For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10 + (100+10)*20 = 2350 Euro.

Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.

The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested, or in a higher quality class, but not in a lower one.


Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1 <= c <= 100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.


Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12
Sample Output
330
1344

/*

 * File:   main.cpp
 * Author: Administrator
 *
 * Created on 2012年3月26日, 下午8:17
 */
#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
using namespace std;
const int MAX = 110;
int sum[MAX];
int price[MAX];
int dp[MAX];


/*
 * 首先对于POJ又多了一个认识,就是T用while输入的话会WA,这是为什么呢?不明白,其次对于这样
 * 一般的DP,算是多了一个DP的思想,把问题化成最优子问题,关键是子问题少而容易求的。此题的
 * 思路就是:先按从小到大的顺序将要处理的数据按价格排列(此题降低了难度而已经给好了),为什么
 * 保持从从小到大呢?原因很简单就是我们可以从第i位向前连续的并了,绝对不会出现跳跃的并。
 * 证明:如果出现跳跃的并的话,那么中间必然出现独立的环节,而他们的价格比i位的价格要低,因此
 * 跳跃就不是最优的方案,因此跳跃就不会成立。如此而来问题就变得很简单,将问题化为最有子问题时,
 * 变得简洁而明朗。
 */
int main() {
    int T;
    int n;
    scanf("%d", &T); /*居然用while写在POJ是WA,谨记啊!*/
    while (T--) {
        scanf("%d", &n);
        sum[0] = 0;
        int temp;
        for (int i = 1; i <= n; i++) {
            scanf("%d%d", &temp, &price[i]);
            sum[i] = sum[i - 1] + temp;
        }


        for (int i = 1; i <= n; i++) {
            dp[i] = (sum[i] + 10) * price[i];
            for (int j = 1; j < i; j++) {
                dp[i] = min(dp[j]+(sum[i] - sum[j] + 10) * price[i], dp[i]);
            }
        }
        printf("%d\n", dp[n]);
    }


    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值