hdu5494 Card Game(BestCoder Round #58 (div.2))

Card Game

Accepts: 432
Submissions: 628
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description

Soda and Beta are good friends. They are going to play a card game today. Soda has n cards with number a1,a2,...,an while Beta has n cards with number b1,b2,...,bn . First, they choose a number m no larger than n . Then they both randomly select m cards from their own n cards. The one with larger sum of the selected cards will win. Soda wants to know if he can always win no mater what cards will be randomly selected from him and Beta.

Input

There are multiple test cases. The first line of input contains an integer T(1T100) , indicating the number of test cases. For each test case: The first line contains two integer n and m (1mn500) . The second line contains n integers a1,a2,...,an (1ai1000) denoting Soda's cards. The third line contains n integers b1,b2,...,bn (1bi1000) denoting Beta's cards.

Output

For each test case, output "YES" (without the quotes) if Soda can always win, otherwise output "NO" (without the quotes) in a single line.

Sample Input
2
3 1
4 5 6
1 2 3
5 2
3 4 7 8 9
3 4 5 2 3
Sample Output
YES
NO
 
   
题意:两个人玩游戏;每人有一个序列,共n个数,从中取出m个数,比较m个数的和的大小。
分析:只要第一个人的最小的数比第二个人最大的数还要大就可以了。
 
   
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int main ()
{
    int T,n,m;
    int a[1111],b[1111];
    cin>>T;
    while (T--)
    {
        cin>>n>>m;
        for (int i=0; i<n; i++)
            cin>>a[i];
        for (int i=0; i<n; i++)
            cin>>b[i];
        sort(a, a+n);
        sort(b, b+n);
        int suma=0,sumb=0;
        for (int i=1; i<=m; i++)
        {
            suma+=a[i-1];
            sumb+=b[n-i];
        }
        if (suma>sumb)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值