hdu5504 GT and sequence(BestCoder Round #60 )

GT and sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 334 Accepted Submission(s): 85


Problem Description
You are given a sequence of N integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than 2631 .

Input
In the first line there is a number T (test numbers).

For each test,in the first line there is a number N ,and in the next line there are N numbers.

1T1000
1N62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

Output
For each test case,output the answer.

Sample Input
  
  
1 3 1 2 3

Sample Output
  
  
6

Source

题意:给定一个序列,从中选出任意个数的乘积最大值。
分析:此题太多坑,得慢慢发现。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int main()
{
    int T;
    ll n,x,sum;
    cin>>T;
    while(T--)
    {
        cin>>n;
        sum = 0;
        int k=0,re=0;
        ll maxx = -INF;
        for(int i=0; i<n; i++)
        {
            cin>>x;
            if(x == 0) {re++; continue;}
            if(x < 0)
            {
                k++;
                maxx = max(maxx, x);
            }
            if(i == re) sum = x;
            else sum *= x;
        }
        //cout<<re<<" "<<k<<endl;
        if(k%2&&n!=1&&!(k==1&&re+k==n)) sum /= maxx;
        if(re>0&&(sum<0||n==1)) sum = 0;
        
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值