poj3107(树形dp)

Godfather
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5586 Accepted: 1950

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair aibi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

Source

Northeastern Europe 2005, Northern Subregion

题意:给定一颗n个节点的树,删除其中一个节点,树被分为很多块,分出来块最小的就是Godfather;求所有的这样的Godfather,按升序输出。
分析:删除一个节点,分成的块就是该点的父结点所在的块和其所有子节点的块,每次找最大的块,然后在找出的所有块中找出最小的块。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

struct node
{
    int v;
    node *next;
}tree[MAXN], *head[MAXN];
int pre,n,dp[MAXN];//dp用来装每个结点的子节点数
int num[MAXN],ans,tot;//num用来装最后的答案

void init()//初始化
{
    pre = 1; ans = INF;
    CL(dp, 0);
    CL(head, NULL);
}

void add(int a, int b)//加边,即建树
{
    tree[pre].v = a;
    tree[pre].next = head[b]; head[b] = &tree[pre++];
    tree[pre].v = b;
    tree[pre].next = head[a]; head[a] = &tree[pre++];
}

void dfs(int son, int father)//记录每个结点的子节点数
{
    node *p = head[son];
    dp[son] = 1;
    while(p != NULL)
    {
        if(p->v != father)
        {
            dfs(p->v, son);
            dp[son] += dp[p->v];
        }
        p = p->next;
    }
}

void dp_tree(int son, int father)
{
    int maxx = 0;
    node *p = head[son];
    while(p != NULL)
    {
        if(p->v != father)
        {
            dp_tree(p->v, son);
            maxx = max(dp[p->v], maxx);
        }
        p = p->next;
    }
    //更新答案
    maxx = max(n-dp[son], maxx);
    if(maxx < ans)
    {
        tot = 1;
        ans = maxx;
        num[tot] = son;
    }
    else if(maxx == ans)
    {
        tot++;
        num[tot] = son;
    }
}

int main()
{
    int u,v;
    while(scanf("%d",&n)==1)
    {
        init();
        for(int i=1; i<n; i++)
            scanf("%d%d",&u,&v), add(u, v);
        dfs(1, 0);
        dp_tree(1, 0);
        sort(num+1, num+tot+1);
        printf ("%d",num[1]);
        for(int i=2; i<=tot; i++)
            printf (" %d",num[i]);
        printf ("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值