PAT 1018 Public Bike Management(Dijkstra 最短路)

22 篇文章 0 订阅
9 篇文章 0 订阅

1018. Public Bike Management (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:

3 0->2->3 0

n^2的Dijkstra求最短路,同时把所有最短路的要发出和收集自行车的情况暴力的记录下来,

最后选取最优的,dfs找回去

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <vector>

using namespace std;
typedef long long int LL;
const int maxn=1e3+5;
const int MAX=1e9;
typedef pair<int,int> p;
int cmax,n,s,m;
int a[maxn][maxn];
int d[maxn];
int vis[maxn];
vector<int> col[maxn];
vector<int> sed[maxn];
int c[maxn];
vector<p> pre[maxn];
void fun(int j,int e)
{
  for(int k=0;k<sed[e].size();k++)
  {
    if(cmax-c[j]<0)
    {
      sed[j].push_back(sed[e][k]);
      col[j].push_back(col[e][k]+abs(cmax-c[j]));
    }
    else if(cmax-c[j]>0)
    {
      col[j].push_back(max(0,col[e][k]-cmax+c[j]));
      sed[j].push_back(sed[e][k]+max(0,cmax-c[j]-col[e][k]));
    }
    else if(cmax-c[j]==0)
    {
      sed[j].push_back(sed[e][k]);
      col[j].push_back(col[e][k]);
    }
    pre[j].push_back(make_pair(e,k));
  }
}
void Dijkstra()
{
  for(int i=0;i<=n;i++)
    d[i]=MAX;
  memset(vis,0,sizeof(vis));
  d[0]=0;
  pre[0].push_back(make_pair(-1,-1));
  sed[0].push_back(0);
  col[0].push_back(0);
  for(int i=0;i<=n;i++)
  {
    int m=MAX;
    int e;
    for(int j=0;j<=n;j++)
      if(!vis[j]&&m>d[j])
        m=d[j],e=j;
    vis[e]=1;
    for(int j=0;j<=n;j++)
    {
      if(!vis[j]&&d[j]>d[e]+a[e][j])
      {
        d[j]=d[e]+a[e][j];
        sed[j].clear();
        col[j].clear();
        pre[j].clear();
        fun(j,e);
      }
      else if(!vis[j]&&d[j]==d[e]+a[e][j])
        fun(j,e);
    }
  }
}
void dfs(int ss,int x)
{
  if(ss==-1&&x==-1)
    return;
  dfs(pre[ss][x].first,pre[ss][x].second);
  if(ss==s)
    printf("%d",ss);
  else
    printf("%d->",ss);
}
int main()
{
  int x,y,z;
  scanf("%d%d%d%d",&cmax,&n,&s,&m);
  cmax/=2;
  for(int i=0;i<=n;i++)
    for(int j=0;j<=n;j++)
      if(i==j) a[i][j]=0;
      else
        a[i][j]=MAX;
  for(int i=1;i<=n;i++)
    scanf("%d",&c[i]);
  for(int i=1;i<=m;i++)
    scanf("%d%d%d",&x,&y,&z),
    a[x][y]=a[y][x]=min(a[x][y],z);
  Dijkstra();
  int pos;
  int mm2=MAX;
  for(int i=0;i<sed[s].size();i++)
  {
    if(mm2>sed[s][i])
      pos=i,mm2=sed[s][i];
    else if(mm2==sed[s][i]&&col[s][i]<col[s][pos])
      pos=i,mm2=sed[s][i];
  }
  printf("%d ",sed[s][pos]);
  dfs(s,pos);
  printf(" %d\n",col[s][pos]);
  return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值