PAT 1012 The Best Rank

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
#include<iostream>
#include<string>
using namespace std;
struct Student
{
  string id;
  int Cgrade;
  int Mgrade;
  int Egrade;
  int average;
  int cRank;
  int mRank;
  int eRank;
  int aRank;
}stu[2000],sstu[2000];
int Average(const int  c,const int m,const int e)
{
  return (c+m+e)/3;
}
int max(const int cr,const int mr,const int er,const int ar,char &ch)
{
  int temp=ar<(er<(cr<mr?cr:mr)?er:(cr<mr?cr:mr))?ar:(er<(cr<mr?cr:mr)?er:(cr<mr?cr:mr));
  if (temp==ar)
    ch='A';  
  else if(temp==cr)
    ch='C';
  else if (temp==mr)
    ch='M';
  else if (temp==er)
    ch='E';
  return temp;
}
int main()
{
  int num;//输入学生数量
  int snum;//查找学生编号数量
  cin>>num>>snum;
  for(int i=0;i<num;i++)
  {
    cin>>stu[i].id>>stu[i].Cgrade>>stu[i].Mgrade>>stu[i].Egrade;
    stu[i].average=Average(stu[i].Cgrade,stu[i].Mgrade,stu[i].Egrade);
  }
  for(int i=0;i<num;i++)
  {
    stu[i].cRank=1;
    stu[i].mRank=1;
    stu[i].aRank=1;
    stu[i].eRank=1;
    for(int j=0;j<num;j++)
    {    
        if(stu[i].Cgrade<stu[j].Cgrade)
          stu[i].cRank++;  
        if(stu[i].Mgrade<stu[j].Mgrade)
          stu[i].mRank++;
        if(stu[i].Egrade<stu[j].Egrade)
          stu[i].eRank++;
        if(stu[i].average<stu[j].average)
          stu[i].aRank++;
    }
  }
  for(int i=0;i<snum;i++)
    cin>>sstu[i].id;
  for(int i=0;i<snum;i++)
  {
    bool flag=false;
    for(int j=0;j<num;j++)
    {
      if(sstu[i].id==stu[j].id)
      {
        flag=true;
        char ch;
        int temp=max(stu[j].cRank,stu[j].mRank,stu[j].eRank,stu[j].aRank,ch);
        cout<<temp<<" "<<ch<<endl;
        break;
      }
    }
    if(flag==false)
      cout <<"N/A"<<endl;
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值