PAT 甲级 1026 Table Tennis(模拟)

6 篇文章 0 订阅

1026. Table Tennis (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2
模拟题:
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <queue>

using namespace std;
#define INF 21*3600
#define MAX 10000
int CurrTime[MAX+5];
int numTable[MAX+5];//桌子被玩的次数
//用户的结构体
struct Player
{
    int startTime;//到达的时间
    int waitTime;//等待的时间
    int playTime;//玩耍的时间
}VipPlayer[MAX+5],OriPlayer[MAX+5];
int n;//n个人
int k,m;//桌子的数量,vip桌子的数量
int cmp(Player a,Player b) {return a.startTime<b.startTime;}//比较函数,快速排序
int VipNumber;//会员的人数
int OriNumber;//普通的人数
bool vipTag[MAX+5];//标记vip桌子
void printTime(int time)
{
    int hh,mm,ss;
    ss=time%60;
    mm=time/60%60;
    hh=time/3600;
    printf("%02d:%02d:%02d ",hh,mm,ss);
}
int main()
{
    scanf("%d",&n);
    int hh,mm,ss,time,tag;
    VipNumber=1;OriNumber=1;
    for(int i=1;i<=n;i++)
    {
        scanf("%d:%d:%d",&hh,&mm,&ss);
        int sum=hh*3600+mm*60+ss;
        scanf("%d%d",&time,&tag);
        if(time>120)//如果超过两个小时,要进行限制
            time=120;
        if(hh>=21) continue;//如果超出营业时间,要进行限制
        if(tag)//如果是vip
        {
            VipPlayer[VipNumber].startTime=sum;
            VipPlayer[VipNumber].waitTime=0;
            VipPlayer[VipNumber++].playTime=time;
        }
        else//如果不是
        {
            OriPlayer[OriNumber].startTime=sum;
            OriPlayer[OriNumber].waitTime=0;
            OriPlayer[OriNumber++].playTime=time;
        }
    }
    scanf("%d%d",&k,&m);//输入桌子数量和vip桌子数量
    int xx;memset(vipTag,0,sizeof(vipTag));
    memset(numTable,0,sizeof(numTable));
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&xx);
        vipTag[xx]=1;
    }
    //对普通和vip进行排序
    sort(VipPlayer+1,VipPlayer+VipNumber,cmp);
    sort(OriPlayer+1,OriPlayer+OriNumber,cmp);
    int i=1,j=1;
    int index=-1;
    for(int i=1;i<=k;i++)
        CurrTime[i]=8*3600;
    while(i<VipNumber||j<OriNumber)
    {
        int minTime=INF,VipTime=INF,OriTime=INF;
        for(int p=1;p<=k;p++)
        {
            if(CurrTime[p]<minTime)
            {
                minTime=CurrTime[p];
                index=p;
            }
        }
        if(i>VipNumber&&j>OriNumber)
            break;
        if(i<VipNumber) {VipTime=max(VipPlayer[i].startTime,minTime);}
        if(j<OriNumber) {OriTime=max(OriPlayer[j].startTime,minTime);}
        bool VipServe=true;
        if(VipTime>OriTime&&OriTime<21*3600) {VipServe=false;}
        else if(OriTime>VipTime&&VipTime<21*3600) {VipServe=true;}
        else if(OriTime==VipTime&&OriTime<21*3600)
        {
            if(vipTag[index]||(!vipTag[index]&&VipPlayer[i].startTime<OriPlayer[j].startTime))
                VipServe=true;
            else
                VipServe=false;
        }
        else if(OriTime==21*3600&&VipTime==21*3600)
        {
            break;
        }
        //判断当前桌子可以为谁服务
        if(VipServe)
        {
            
            if(!vipTag[index])
            {
                for(int p=1;p<=k;p++)
                {
                    if(vipTag[p]&&CurrTime[p]==minTime)
                    {
                        
                        index=p;
                    }
                }
                
            }
            VipPlayer[i].waitTime=VipTime;
            CurrTime[index]=VipTime+VipPlayer[i].playTime*60;
            numTable[index]++;
            
            printTime(VipPlayer[i].startTime);
            printTime(VipPlayer[i].waitTime);
            printf("%d\n",(VipPlayer[i].waitTime-VipPlayer[i].startTime+30)/60);
            i++;
        }
        else
        {
            OriPlayer[j].waitTime=OriTime;
            CurrTime[index]=OriTime+OriPlayer[j].playTime*60;
            numTable[index]++;
            
            printTime(OriPlayer[j].startTime);
            printTime(OriPlayer[j].waitTime);
            printf("%d\n",(OriPlayer[j].waitTime-OriPlayer[j].startTime+30)/60);
            j++;
        }
        
        
    }
    printf("%d",numTable[1]);
    for(int i=2;i<=k;i++)
        printf(" %d",numTable[i]);
    printf("\n");
    return 0;
    
    
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值