关闭

在ubuntu14.04上安装emacs24.4

1780人阅读 评论(1) 收藏 举报
分类:

when configure the emacs:   error like this!

You seem to be running X, but no X development libraries
were found. You should install the relevant development files for X
and for the toolkit you want, such as Gtk+, Lesstif or Motif. Also make
sure you have development files for image handling, i.e.
tiff, gif, jpeg, png and xpm.
If you are sure you want Emacs compiled without X window support, pass
--without-x
to configure.

装GTK+等图形开发库
sudo apt-get install libgtk2.0-dev

几个图像开发库
sudo apt-get install libxpm-dev
sudo apt-get install libjpeg62-dev
sudo apt-get install libgif-dev
sudo apt-get install libtiff4-dev

last one: 
sudo apt-get install libncurses5-dev

./configure
make
make install

run it in window
emacs 

run it without any window
emacs -nw

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:445774次
    • 积分:5570
    • 等级:
    • 排名:第4944名
    • 原创:4篇
    • 转载:517篇
    • 译文:1篇
    • 评论:17条
    文章分类
    最新评论