ZOJ 3819 Average Score

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3819


题面:

Average Score

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input
2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1
Sample Output
4 4
2 4


题意:

该学生在A班会拉低该班成绩,在B班会提高该班成绩,求该学生的成绩能取到的最大值和最小值。因为是整数有点特别,注意下整除的情况就好。


代码1:

#include <iostream>
using namespace std;
int main()
{
	int t,n,m,sum1,sum2,tmp,minn,maxx;
	cin>>t;
	while(t--)
	{
		sum1=sum2=0;
	    cin>>n>>m;
		for(int i=1;i<n;i++)
		{
			cin>>tmp;
			sum1+=tmp;
		}
		for(int i=0;i<m;i++)
		{
			cin>>tmp;
			sum2+=tmp;
		}
		if(sum2%m==0)minn=sum2/m+1;
		else minn=(1.0*sum2/m)+1;
		if(sum1%(n-1)==0)maxx=sum1/(n-1)-1;
		else maxx=sum1/(n-1);
		cout<<minn<<" "<<maxx<<endl; 
	}
	return 0;
} 

代码2:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <cmath>
#include <cstdlib>
#include <set>
#include <algorithm>
#define LL long long
using namespace std;
LL a,b,s;

int main()
{
	int total1,n,m,total2,minn,maxx,tmp,t;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		total1=total2=0;
		for(int i=1;i<n;i++)
		{
			cin>>tmp;
			total1+=tmp;
		}
		for(int i=1;i<=m;i++)
		{
			cin>>tmp;
			total2+=tmp;
		}
		for(int i=0;i<=100;i++)
		{
			if(i*(n-1)>=total1)
			{
				maxx=i-1;
				break;
			}
		}
		for(int i=100;i>=0;i--)
		{
			if(i*m<=total2)
			{
				minn=i+1;
				break;
			}
		}
		cout<<minn<<" "<<maxx<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值