HDU 3836 Equivalent Sets (tarjan求强联通分量)

题目链接:HDU 3836


题面:

Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 4074    Accepted Submission(s): 1433


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

Output
For each case, output a single integer: the minimum steps needed.
 

Sample Input
  
  
4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
 

Source


知识点:

     这篇tarjan入门讲的很不错,可以用作入门。

题意:

     给定一张有向图,问最少加几条边可以构成全图强联通,即强联通分量个数为1.


解题:

     首先用tarjan算法进行染色缩点,强联通图中各个点的入度出度一定都大于0,若有点的入度为0,则肯定要加一条入边,若有点的出度为0,则肯定要加一条出边,分别统计出入度数为0的点的个数,取两者的大者作为结果。(肯定存在一种构造方式使得图可联通,还需特判原来就是一个联通块的情况,直接输出0即可)。


代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define sz1 50010
#define sz2 20010
using namespace std;
struct edge
{
	int fm,to,nxt;
}store[sz1];
int head[sz2],stack[sz2],dfn[sz2],low[sz2];
char vis[sz2];
int p,cnt,sig,tt,color[sz2],in[sz2],out[sz2];
void addedge(int fm,int to)
{
	store[p].nxt=head[fm];
	head[fm]=p;
	store[p].fm=fm;
	store[p++].to=to;
}
void Tarjan(int u) 
{  
	vis[u]=1;  
	low[u]=dfn[u]=cnt++;  
	stack[++tt]=u;  
	for(int i=head[u];~i;i=store[i].nxt)  
	{  
		int v=store[i].to;  
		if(vis[v]==0)Tarjan(v);  
		if(vis[v]==1)low[u]=min(low[u],low[v]);  
	}  
	if(dfn[u]==low[u])  
	{  
		sig++;  
		do  
		{  
			low[stack[tt]]=sig;  
			color[stack[tt]]=sig;  
			vis[stack[tt]]=-1;  
		}  
		while(stack[tt--]!=u);  
	}  
}  
int main()
{
    int n,m,a,b;
	while(~scanf("%d%d",&n,&m))
    {
	   p=cnt=tt=sig=0;
       memset(head,-1,sizeof(head));
       memset(vis,0,sizeof(vis));
	   memset(out,0,sizeof(out));
	   memset(in,0,sizeof(in));
	   for(int i=0;i<m;i++)
	   {
         scanf("%d%d",&a,&b);
		 addedge(a,b);
	   }
	   for(int i=1;i<=n;i++)
		   if(!vis[i])
			   Tarjan(i);
	   if(sig==1)
	   {
		   printf("%d\n",0);
		   continue;
	   }
	   for(int i=0;i<m;i++)
	   {
          a=store[i].fm;
		  b=store[i].to;
		  if(color[a]!=color[b])
		  {
			  out[color[a]]++;
			  in[color[b]]++;
		  }
	   }
	   a=b=0;
	   for(int i=1;i<=sig;i++)
	   {
		   if(in[i]==0)
			   a++;
		   if(out[i]==0)
			   b++;
	   }
	   printf("%d\n",max(a,b));
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值