关闭

Xamarin.iOS项目提示error MSB3174:”TargetFrameworkVersion”的值无效

312人阅读 评论(0) 收藏 举报
分类:

Xamarin.iOS项目提示error MSB3174:”TargetFrameworkVersion”的值无效

错误信息:MSBulid\14.0\bin\Microsoft.Common.CurrentVersion.targets(3506.5): error MSB3174:”TargetFrameworkVersion”的值无效
这个问题会在Xamarin.iOS和Xamarin.Android中出现。根据项目类型不同,解决办法不同。
在Xamarin.iOS项目中,需要修改该项目的.csproj文件。在其中找到以下代码:
< GenerateManifests >true< / GenerateManifests >
将其中的true设置false。
在Xamarin.Android项目中,需要修改该项目的.csproj文件。在其中,找到第一个<PropertyGroup>分支。在其中添加以下配置项:
<TargetFrameworkVersion>v6.0</TargetFrameworkVersion>
将其中的6.0改为Android API的版本。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:422896次
    • 积分:10845
    • 等级:
    • 排名:第1482名
    • 原创:689篇
    • 转载:0篇
    • 译文:0篇
    • 评论:57条