关闭

解决configure: error: Subversion requires SQLite

7191人阅读 评论(0) 收藏 举报
分类:
svn error:Subversion requires SQLite解决
 
在安装 subversion时候
#tar xvjf subversion-1.6.3.tar
# ./configure --prefix=/data1/subversion --with-apxs=/data1/apache2/bin/apxs  --with-apr-util=/data1/apache2/bin/apu-1-config --with-apr=/data1/apache2/bin/apr-1-config  
在以上编译过程中可能会出现 configure: error: Subversion requires SQLite
 
 
可以http://www.sqlite.org/sqlite-amalgamation-3.6.13.tar.gz 可以下载到最新的Sqlite版本sqlite-amalgamation-3.6.13.tar.gz安装Sqlite3.6.13 tar zxvf sqlite-amalgamation-3.6.13.tar.gz 进入文件夹sqlite-amalgamation找到sqlite3.c将其复制到 
subversion-1.6.2/sqlite-amalgamation/sqlite3.c  
 
 
然后继续执行subversion 的make 和make install操作。
1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:1625322次
    • 积分:15638
    • 等级:
    • 排名:第685名
    • 原创:66篇
    • 转载:956篇
    • 译文:11篇
    • 评论:27条
    最新评论