2016 Multi-University Training Contest 3 Rower Bo

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 867    Accepted Submission(s): 296
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at  (0,a)  at first.He wants to get to origin  (0,0)  by boat.Boat speed relative to water is  v1 ,and the speed of the water flow is  v2 .He will adjust the direction of  v1  to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers  a,v1,v2 .

0a100 0v1,v2,100 a,v1,v2  are integers
 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than  104 , your solution will be accepted.
 

Sample Input
  
  
2 3 3 2 4 3
 

Sample Output
  
  
Infinity 1.1428571429
 

Source


首先这个题微分方程强解显然是可以的,但是可以发现如果设参比较巧妙就能得到很方便的做法。

先分解v_1v1

Alt text

设船到原点的距离是rr,容易列出方程

\frac{ dr}{ dt}=v_2\cos \theta-v_1dtdr=v2cosθv1

\frac{ dx}{ dt}=v_2-v_1\cos \thetadtdx=v2v1cosθ

上下界都是清晰的,定积分一下:

0-a=v_2\int_0^T\cos\theta{ d}t-v_1T0a=v20Tcosθdtv1T

0-0=v_2T-v_1\int_0^T\cos\theta{ d}t00=v2Tv10Tcosθdt

直接把第一个式子代到第二个里面

v_2T=\frac{v_1}{v_2}(-a+v_1T)v2T=v2v1(a+v1T)

T=\frac{v_1a}{{v_1}^2-{v_2}^2}T=v12v22v1a

这样就很Simple地解完了,到达不了的情况就是v_1< v_2v1<v2(或者a>0a>0v_1=v_2v1=v2)。

 
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    double a,x,y;
    while(cin>>a>>x>>y)
    {
        if(a==0)
        {
        printf("0\n");
        continue;
        }
        double ans=(a*x)/fabs(y*y-x*x);
        if(y>=x)
        printf("Infinity\n");
        
        else
        cout<<ans<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值