1003. Emergency(最短路)

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

解题思路:这就是一个最短路的题目,用Dijkstra算法就可以了,要计算最短路的数量,还要考虑到救援队数量最多。。。


代码如下:

#include<bits/stdc++.h>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
int n,m,s,d;
///用dis[]记录路径距离,vis[]标记点,p[]记录救援队的数量;
int a[505][505],dis[505],p[505],v[505];
int vis[505],f[505],way[505];///f[]记录父节点,may[]最短路径的条数
void Dijkstra()
{
  memset(dis,INF,sizeof(dis));
  for(int i=0;i<n;i++)
    f[i]=i;
  dis[s]=0;///距离
  p[s]=v[s];///出事的救援队数量
  way[s]=1;///出事的路径条数
  for(int i=1;i<n;i++)
  {
    int min=INF,t=-1;
    for(int j=0;j<n;j++)
      if(!vis[j]&&dis[j]<min)
      {min=dis[j]; t=j;}
    if(t==-1) break;
    vis[t]=1;///标记
    for(int j=0;j<n;j++)
    {
      if(vis[j]) continue;
      if(dis[t]+a[t][j]<dis[j]){
        dis[j]=dis[t]+a[t][j];
        p[j]=v[j]+p[t];
        f[j]=t;
        way[j]=way[t];
      }else if(dis[t]+a[t][j]==dis[j]){
        if(p[j]<p[t]+v[j]){
          p[j]=p[t]+v[j];
          f[j]=t;
        }
        way[j]+=way[t];
      }
    }
  } 
}
int main()
{
  int b,c,z;
  memset(a,INF,sizeof(a));
  scanf("%d %d %d %d",&n,&m,&s,&d);
  for(int i=0;i<n;i++)
    scanf("%d",&v[i]);
  for(int i=0;i<m;i++)
  {
    scanf("%d %d %d",&b,&c,&z);
    a[b][c]=a[c][b]=z;
  }
  Dijkstra();
  printf("%d %d\n",way[d],p[d]);
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值