POJ 3262 Protecting the Flowers (贪心 + 优化)

4 篇文章 0 订阅
Protecting the Flowers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7477 Accepted: 3014

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer  N 
Lines 2.. N+1: Each line contains two space-separated integers,  Ti and  Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

解题思路:

由少推到多,假设有两头牛X和Y,则其参数为T_X,D_X,T_Y,D_Y

当先送X时:2*T_X*D_Y

当先送Y时:2*T_Y*D_X

对两式同时除以2*D_X*D_Y

即:最后得到的为T和D的比值

两个是这样,那么推出N个也是这样的。

最后按照比值贪心一次即可。


代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define LL long long
using namespace std;
const int maxn=1e6+10;
struct P{
    int d,t;
    double z;
}a[maxn];
LL b[maxn];
bool cmp(P a,P b)
{
    return a.z<b.z;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d %d",&a[i].t,&a[i].d);
        a[i].z=1.0*a[i].t/(a[i].d*1.0);
    }
    sort(a,a+n,cmp);
    b[0]=0;
    for(int i=1;i<n;i++)
        b[i]=b[i-1]+a[i-1].t;
    LL ans=0;
    for(int i=0;i<n;i++)
        ans+=a[i].d*2*b[i];
    printf("%lld\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值