HDU 6201 源点和汇点


转载于:http://blog.csdn.net/a15110103117/article/details/77925858


transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 284    Accepted Submission(s): 125



Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.



Input
The first line contains an integer T (1≤T≤10) , the number of test cases. 
For each test case:
first line contains an integer n (2≤n≤100000) means the number of cities;
second line contains n numbers, the ith number means the prices in ith city; (1≤Price≤10000) 
then follows n−1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is zkm (1≤z≤1000). 



Output
For each test case, output a single number in a line: the maximum money he can get.



Sample Input


10 40 15 30 
1 2 30
1 3 2
3 4 10


Sample Output
8


Source
2017 ACM/ICPC Asia Regional Shenyang Online 


Recommend

liuyiding


题意:

给出一棵树,每个点都有点权,问取两个点,使得T-S-sumw为最大(T为终点的点权,S为起点的点权,sumw为S到T的路径长度),可取相同的点。

思路:

正解应该是树dp,想看树dp的请到隔壁,我蒟蒻并不会,网络赛上是队友敲的。我这里给出另外一种解法,思路来自ACM贴吧群dalao。

求最短路(我跑的是最长路),你加个源点,汇点,源点到树上的点边权为ci,树上点到汇点边权为-ci,ci为该点点权,树上点与点之间边权也取反,转化一下也可以跑最短。

费用流也可做的样子?


代码:

#include <stdio.h>
#include <algorithm>
#include <queue>
#include <string.h>
using namespace std;
struct jj
{
    int v,c,next;
}w[400000];
int a[100001],h[100002],numw;
void insert(int u,int v,int c)
{
    w[numw].v=v;
    w[numw].c=c;
    w[numw].next=h[u];
    h[u]=numw++;
}
int spfa(int s,int t)
{
    int i,dis[100002],v[100002];
    queue<int>q;
    memset(dis,0,sizeof(dis));
    memset(v,0,sizeof(v));
    q.push(s);
    while(q.empty()==0)
    {
        s=q.front();
        q.pop();
        v[s]=0;
        for(i=h[s];i!=-1;i=w[i].next)
        {
            if(dis[w[i].v]<dis[s]+w[i].c)
            {
                dis[w[i].v]=dis[s]+w[i].c;
                if(v[w[i].v]==0)
                {
                    v[w[i].v]=1;
                    q.push(w[i].v);
                }
            }
        }
    }
    return dis[t];
}
int main()
{
    int t,n,i,u,v,c;
    scanf("%d",&t);
    while(t--)
    {
        memset(h,-1,sizeof(h));
        numw=0;
        scanf("%d",&n);
        for(i=1;n>=i;i++)
        {
            scanf("%d",&a[i]);
            insert(0,i,a[i]);                   //实际上我把它当汇点了
            insert(i,n+1,-a[i]);                //那么这个就是源点
        }
        for(i=1;n>i;i++)
        {
            scanf("%d %d %d",&u,&v,&c);
            insert(u,v,-c);                 //题目中跑路所要的花费
            insert(v,u,-c);
        }
        printf("%d\n",spfa(0,n+1));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值