hdu 3183 A Magic Lamp

hdu 3183 A Magic Lamp

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3070 Accepted Submission(s): 1204

Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.

Sample Input
178543 4
1000001 1
100001 2
12345 2
54321 2

Sample Output
13
1
0
123
321

题目大意:给你一串数字,让你删除其中m个数字后组成的数字最小,不能改变位置;

思路:设置数字的长度等于l,就是找l-m个数字组成的数字最小;
我们找l-m个数字,肯定是从头开始找,并且找最小的那个。

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    int n;
    while(cin>>s>>n)
    {
        int l=s.size();
        int j=0;
        string ans;
        for(int i=1;i<=(l-n);i++)//取l-n个数 
        {
            int p=j; //重新设置位置;
            char minn=s[j];//重新设置最小的数;
            for( ;j<(n+i);j++)//从第j个开始取最小的数 
            {
                if(minn>s[j])
                {
                    minn=s[j];                  
                    p=j;
                }   
            }
            j=p+1;//重新设置下一个位置;
            if(minn=='0'&&ans=="");
            else
                ans+=minn;//把找到的最小的数给ans; 
        }
        if(ans=="")
            cout<<"0\n";
        else
            cout<<ans<<endl;
    }
    return 0;
}

代码提交地址:http://acm.hdu.edu.cn/showproblem.php?pid=3183

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值