HDU1010 - Tempter of the Bone - dfs

1.题目描述:

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 117353    Accepted Submission(s): 31777


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author
ZHANG, Zheng
 

Source
 

Recommend
JGShining
2.题意概述:

天使受困,他的朋友来救他,问你在规定时间内能否解救成功

3.解题思路:

直接dfs就行,不过如果地图有多个朋友则可以变起点为终点来搜。

4.AC代码:

#include <stdio.h>
#include <string.h>
#include <cmath>
#define N 8
using namespace std;
char mp[N][N], vis[N][N];
int dir[4][2] = { {0, 1}, {1, 0}, {-1, 0}, {0, -1} };
int n, m, t, ax, ay, bx, by, flag;
int judge(int x, int y)
{
	if (x > 0 && y > 0 && x <= n && y <= m && !vis[x][y] && mp[x][y] != 'X')
		return 1;
	return 0;
}
void dfs(int x, int y, int step)
{
	if (x == bx &&y == by)
	{
		if (step == t)
			flag = 1;
		return;
	}
	vis[x][y] = 1;
	for (int i = 0; i < 4; i++)
	{
		int dx = x + dir[i][0];
		int dy = y + dir[i][1];
		if (judge(dx, dy))
		{
			vis[dx][dy] = 1;
			dfs(dx, dy, step + 1);
			vis[dx][dy] = 0;
			if (flag)
				return;
		}
	}
}
int main()
{
	while (scanf("%d%d%d", &n, &m, &t) != EOF && n + m + t)
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%s", mp[i] + 1);
			for (int j = 1; j <= m; j++)
			{
				if (mp[i][j] == 'S')
				{
					ax = i;
					ay = j;
				}
				else if (mp[i][j] == 'D')
				{
					bx = i;
					by = j;
				}
			}
		}
		memset(vis, 0, sizeof(vis));
		if (abs(ax - bx) + abs(ay - by) > t || (ax + bx + ay + by + t) % 2)	// 奇偶剪枝
		{
			puts("NO");
			continue;
		}
		flag = 0;
		dfs(ax, ay, 0);
		if (flag)
			puts("YES");
		else
			puts("NO");
	}
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值