HDU1556 - Color the ball - 思维+线段树/树状数组/前缀和

1.题目描述:

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19215    Accepted Submission(s): 9600


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1542  1394  1255  1541  3397 
3.解题思路:

一种做法是前缀和思想

比如原先数据为000000000

我要对第3到8数全部加1

正常写法是for 3...8,复杂度是O(N),前缀和操作只要3处+1,9处-1,那么就是00100000-10

那么对数据求一遍前缀和就是0011111100

这里前缀和查询复杂度还是O(N),还可以用BIT(树状数组)优化到logN,这个代码以后补。

线段树也是这个思想,对l和r内区间进行update,维护父亲为儿子的和,最后输出t[1].w就行。

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 200100
#define lson root << 1
#define rson root << 1 | 1
#define N 1111
#define eps 1e-6
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
const int mod = 1e9 + 7;
typedef long long ll;
typedef unsigned long long ull;
struct tree
{
    int l, r, w;
} t[maxn * 4];
int ans[maxn];
void build(int l, int r, int root)
{
    t[root].l = l;
    t[root].r = r;
    t[root].w = 0;
    if (l == r)
    {
    //    scanf("%d", &t[root].w);
        return;
    }
    int mid = l + r >> 1;
    build(l, mid, lson);
    build(mid + 1, r, rson);
//    pushup(root);
}
void update(int val, int l, int r, int root)
{
    if (t[root].l == l && t[root].r == r)
    {
        t[root].w += val;
        return;
    }
    int mid = t[root].l + t[root].r >> 1;
    if (l > mid)
        update(val, l, r, rson);
    else if (r <= mid)
        update(val, l, r, lson);
    else
    {
        update(val, l, mid, lson);
        update(val, mid + 1, r, rson);
    }
//    pushup(root);
}
void query(int root)
{
    for (int i = t[root].l; i <= t[root].r; i++)
        ans[i] += t[root].w;
    if (t[root].l != t[root].r)
    {
        query(lson);
        query(rson);
    }
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
    long _begin_time = clock();
#endif
    int n;
    while (~scanf("%d", &n), n)
    {
        build(1, n, 1);
        for (int i = 0; i < n; i++)
        {
            int a, b;
            scanf("%d%d", &a, &b);
            update(1, a, b, 1);
        }
        fill(ans, ans + n + 1, 0);
        query(1);
        for (int i = 1; i <= n; i++)
            if (i == 1)
                printf("%d", ans[i]);
            else
                printf(" %d", ans[i]);
        puts("");
    }
#ifndef ONLINE_JUDGE
    long _end_time = clock();
    printf("time = %ld ms.", _end_time - _begin_time);
#endif
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值