关闭

mips cpu低版本gcc编译lua问题总结

最近用到了rt5350,该cpu提供的gcc版本和linux内核都很低。 在编译其他工具库时都没发现问题,结果在编译luasocket,lanes出现问题。 1: lua或者lua的宿主程序必须主动链接pthread库 因为会用到dlopen,如果不主动链接pthread库,会crash。 具体请见https://sourceware.org/bugzilla/attachment.cgi...
阅读(1029) 评论(0)
    个人资料
    • 访问:445759次
    • 积分:5636
    • 等级:
    • 排名:第5723名
    • 原创:98篇
    • 转载:18篇
    • 译文:0篇
    • 评论:118条
    文章分类
    最新评论