hdoj 2601 An easy problem 【技巧(转换思维)】

An easy problem

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8106    Accepted Submission(s): 1973


Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
 

Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 10).
 

Output
For each case, output the number of ways in one line.
 

Sample Input
  
  
2 1 3
 

Sample Output
  
  
0 1
 

Author
Teddy
 

Source
 
思路:
 
        给出一个数n,让你求有多少个i和j能够满足i*j+i+j==n;一般我们都会将其进行变形,然后转化成(n+1)==(i+1)*(j+1)这个式子!也就是当我们输入一个数的时候,我们要求n+1这个数,然后求有多少个两个数的乘积等于这个数!其中i+1>=2且i+1>=j+1;这样其实我们很容易想起将n+1开方,然后找有多少个数能够整除n+1,就行了!
 
代码:
 
#include <stdio.h>
#include <math.h>
int main()
{
	int T;
	__int64 n,t;
	__int64 num;
	scanf("%d",&T);
	while(T--)
	{
		num=0;
		scanf("%I64d",&n);
		n++;
		t=sqrt((double)n);
		for(__int64 i=2;i<=t;i++)
		{
			if(n%i==0)
				num++;
		}
		printf("%I64d\n",num);
	}
	return 0;
}

         
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值