PU_3321Apple Tree



Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?


Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

<pre class="cpp" name="code">#include <stdio.h>
#include <string.h>
#include <vector>

using namespace std;

//vector<int> g[100005];
struct Node
{
    int v;
    struct Node *next;
}g[100005];

int n,m,cnt,low[100005],high[100005],c[100005],flag[100005];

bool mark[100005];

void dfs(int v){  //深搜 
    struct Node *p=g[v].next;
    mark[v]=true;
    cnt++;
    low[v]=cnt;
    while(p){
        if(!mark[p->v])
            dfs(p->v);
        p=p->next;
    }
    high[v]=cnt;
}

int lowbit(int k){
	
    return k&(-k);
}

void Modify(int num, int v){
    while(num <= n){
        c[num]+=v;
        num+=lowbit(num);
    }
}
int Sum(int num){

    int ans=0;
    while(num > 0)
    {
        ans+=c[num];
        num-=lowbit(num);
    }
    return ans;
}

int main()
{
    int i,a,b,ans;
    char temp[10];
    struct Node *p;
    //freopen("in.txt","r",stdin);
    scanf("%d",&n);
    memset(g,0,sizeof(g));
    for(i=1; i<n; i++)
    {
        scanf("%d%d",&a,&b);
        p=new Node;
        p->next=g[a].next;
        p->v=b;
        g[a].next=p;
        p=new Node;
        p->next=g[b].next;
        p->v=a;
        g[b].next=p;
    }
    memset(mark,false,sizeof(mark));	//
    memset(c,0,sizeof(c));	//
    for(i=1; i<=n; i++)		
        flag[i]=1;	 //
    cnt=0;
    dfs(1);
    scanf("%d",&m);
    while(m--)
    {
        scanf("%s",temp);
        if(temp[0] == 'Q')
        {
            scanf("%d",&a);
            ans=high[a]-low[a]+1+Sum(high[a])-Sum(low[a]-1);
            printf("%d\n",ans);
        }
        else
        {
            scanf("%d",&a);
            if(flag[a]) Modify(low[a],-1);
            else Modify(low[a],1);
            flag[a]^=1;
        }
    }
    return 0;
}
/*
**
*具体做法是做一次dfs,记下每个节点的开始时间low[i]和结束时间high[i],那么对于i节点
*的所有子孙的开始时间和结束时间都应位于low[i]和high[i]之间,另外用一个数组c[i]记录附
*加在节点i上的苹果的个数,然后用树状数组统计low[i]到high[i]之间的附加苹果总数。
*这里用树状数组统计区间可以用Sum(high[i])-Sum(low[i]-1)来计算。
**
*/


 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值