HD 2955 Robberies(0-1背包)

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output

  
  
2 4 6
 

题意:Roy想要抢劫银行,每家银行多有一定的金额和被抓到的概率,知道Roy被抓的最大概率P,求Roy在被抓的情况下,抢劫最多。
分析:被抓概率可以转换成安全概率,Roy的安全概率大于1-P时都是安全的。抢劫的金额为0时,肯定是安全的,所以d[0]=1;其他金额初始为最危险的所以概率全为0; 注意精度。
转移方程为:dp[j]=max(dp[j-v[i]]*p[i],dp[j]);
如下代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#define esp 1e-10
#define M 10005
using namespace std;

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		double p[M],sp;//p为抢每个银行的安全概率
		int v[M];
		//memset(dp,0,sizeof(dp));
		double dp[M]={1.0};	//dp为拿完钱后自己的安全概率 初始状态最安全,所以为1.0 
		int n,s=0;
		scanf("%lf%d",&sp, &n);
		sp=1-sp;	//转换成安全概率 
		for(int i=0; i<n; ++i){
			scanf("%d%lf", &v[i],&p[i]);
			s+=v[i];
			p[i]=1-p[i];	//转换成安全概率 
		}
		
		for(int i=0; i<n; ++i){
			for(int j=s; j>=v[i]; --j){
				dp[j]=max(dp[j-v[i]]*p[i],dp[j]);
			}
		}
		for(int i=s; i>=0; --i)
			if(dp[i]-sp>esp){
				printf("%d\n",i);
				break;
			}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值