ZOJ3640 Help Me Escape

Help Me Escape

Time Limit: 2 Seconds Memory Limit: 32768 KB
Background

If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him.
And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.
And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper?
And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground.
And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand;
When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:


After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3
Sample Output

6.889

题意:一个吸血鬼有n条路可以逃出去,每次选择一条路走,当他的攻击力大于这个路上的那个值,他就可以话t天的时间逃出去(t就是那个公式),否则,他的攻击力增加那条路的那个值,求逃出去所花的期望天数。

记忆化搜索做DP,dp[i],i代表他的攻击力,所以转移就要分成两种,逃出去的和攻击力增加的。。详细看代码。。。

/*************************************************************************
	> File Name: zoj3640.cpp
	> Author: tjw
	> Mail: 
	> Created Time: 2014年10月21日 星期二 09时48分11秒
 ************************************************************************/

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#define ll long long
#define ls k<<1
#define rs k<<1|1
using namespace std;
const int MAXN=1000010;
const double op=(1.0+sqrt(5))/2;
double dp[MAXN];
bool vis[MAXN];
int n;
int c[110];
double dfs(int u)
{
    if(vis[u])
        return dp[u];
    vis[u]=1;
    dp[u]=0;
    for(int i=0;i<n;i++)
    {
        if(c[i]<u)
        {
            double temp=op*c[i]*c[i]*1.0;
            int t=(int)temp;
            dp[u]+=1.0*t/n;
        }
        else
            dp[u]+=(1+dfs(u+c[i]))/n*1.0;
    }
    return dp[u];
}
int main()
{
    int f,i;
    while(scanf("%d%d",&n,&f)==2)
    {
        for(i=0;i<n;i++)
            scanf("%d",&c[i]);
        memset(vis,0,sizeof(vis));
        double ans=dfs(f);
        printf("%.3f\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值