山东理工大3561 斐波那契数列

Fibonacci

Time Limit: 2000MS Memory Limit: 131072KB
Problem Description

Fibonacci numbers are well-known as follow:

 

Now given an integer N, please find out whether N can be represented as the sum of several Fibonacci numbers in such a way that the sum does not include any two consecutive Fibonacci numbers.

Input
Multiple test cases, the first line is an integer T (T<=10000), indicating the number of test cases.

Each test case is a line with an integer N (1<=N<=109).

Output
One line per case. If the answer don’t exist, output “-1” (without quotes). Otherwise, your answer should be formatted as “N=f1+f2+…+fn”. N indicates the given number and f1, f2, … , fn indicating the Fibonacci numbers in ascending order. If there are multiple ways, you can output any of them.

Example Input
4
5
6
7
100
Example Output
5=5
6=1+5
7=2+5
100=3+8+89
 
 
 
 
数据一亿,斐波那契数列的第四十项已经超过了一亿,先将数列打表。然后遍历,若数组中没有n,则返回比n小的前一个数,存入另一个数组,然后n减去这个数,继续遍历,
直到n==0为止,或者最后n<0,则没有找到,输出-1.
问题在于,find函数直接调用会不通过,出错接近20次,用一个数接收函数的返回值就ac。还是不懂,哪位大神知道原因的话还请留言。谢谢。
 
 
 
 
#include<stdio.h>


long long a[55];  //一亿,用到long long 


long long find(int x)  //遍历查找 
{
	int i;
	
	for(i=50;i>=0;i--)   //从后向前找,输出距离n最近的一个数 
	{
		if(a[i]<=x)
		return a[i];
	}
}


int main()
{
	int t,i,j;
	long long b[100],n,y;   //b数组接收 
	
	a[0]=1;a[1]=2;
	
	for(i=2;i<=50;i++)    //打表 
	a[i]=a[i-1]+a[i-2]; 
		
	
	
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%lld",&n);
			
			i=0;y=n;    //y接收n 
			
			while(n>0)  //n==0则代表找到这一系列的数 
			{
				int count=find(n);   //必须接收,很费解 
				b[i++]=count;     //储存 
				n=n-count;        //做差 
			}
			
			if(n==0)     //找到这样的一组数 
			{
				printf("%d=",y);    // 输出n,此时为y 
				  
				for(j=i-1;j>0;j--)    //输出前n-1个,带加号 
				printf("%d+",b[j]);
				
				printf("%d\n",b[0]);   //最后一个 
			}
			
			else
			printf("-1\n");    //未找到 
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值