POJ 2318 TOYS (向量叉乘+二分)

传送门:点击打开链接

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16287 Accepted: 7821

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意是给定一个矩形的两点,里面有n条线段,线段不相交而且线段严格从左到右排列,把矩形分成了n-1个区域,给定m个点,问每一个区域内有几个点。


听说暴力也可以过,毕竟给了2s。这个题属于基础几何题,由于给定的直线只有端点,所以,要把端点跟开始给的左右起点联系起来,建立新的坐标点。将每个点与直线的端点做向量,小于0代表点在直线左边,大于0代表点在 直线右边。然后二分去查找点所在的区域,最后记录。


代码实现:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll int
#define mset(a,x) memset(a,x,sizeof(a))

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double esp=1e-6;
const int maxn=5e3+5;
const int mod=1e9+7;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int n,m,x1,x2,Y1,y2,ans[maxn];
struct point{
	int x,y;
	point(){};                               //因为有带参的构造函数,下面无法直接定义,所以加一个无参的构造函数 
	point(int newx,int newy)                 //需要重载-,所以设立一个带参的构造函数 
    {  
        x=newx;y=newy;  
    }  
	point operator -(const point &b)        //两点相减得到向量,故重载一下- 
	{
		return point(x-b.x,y-b.y);
	}
}LL[maxn],rr[maxn];                         //ll记录线段第一个端点,rr记录第二个 

int cross(point a,point b)                  //求向量叉乘 
{
	return a.x*b.y-b.x*a.y;
}

int main()
{
	int x,y,i,j,k;
	while(cin>>n&&n)
	{
		cin>>m>>x1>>Y1>>x2>>y2;
		mset(ans,0);
		for(i=0;i<n;i++)                  //将直线端点构造成点 
		{
			cin>>x>>y;
			LL[i].x=x;
			LL[i].y=Y1;
			rr[i].x=y;
			rr[i].y=y2;
		}
		for(i=0;i<m;i++)
		{
			point p;
			cin>>p.x>>p.y;
			int l=0,r=n,temp=n;          //temp记录查找到的n的值 
			while(l<=r)
			{
				int mid=(l+r)/2;
				if(cross(p-rr[mid],LL[mid]-rr[mid])<=0)   //叉乘小于0,点在线的左边 
				{
					temp=mid;
					r=mid-1;
				}
				else                                      //叉乘大于0,点在线的右边 
				l=mid+1;	
			}
			ans[temp]++;                                  //记录点的位置 
		}
		for(i=0;i<=n;i++)
		{
			printf("%d: %d\n",i,ans[i]); 
		}
		cout<<endl;                                       //注意最后空行 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值