POJ 1269 Intersecting Lines

传送门:点击打开链接

Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16736 Accepted: 7213

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source


题意就是给你四个点,每两点确定一条直线,问两直线是否有交点,有交点输出,没有输出共线或平行。


关键在于判断斜率,因为有斜率不存在的情况,如果是单独求k的话,斜率不存在还要单独拿出来考虑,第一次就没判断k,各种WA。然后可以利用向量的叉乘,若叉乘为0代表两直线平行,再去判断是否共线,这样成功避开了k的取值。最后得到正确结果还是花样WA,竟然是因为G++的问题,看了一眼讨论版才知道,可怕啊。


代码实现:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll int
#define mset(a,x) memset(a,x,sizeof(a))

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double eps=1e-8;
const int maxn=5e5+5;
const int mod=1e9+7;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
struct point{
	double x,y;
	point(){};
	point(double newx,double newy)
	{
		x=newx;y=newy;
	}
	point operator -(const point &b)
	{
		return point(x-b.x,y-b.y);
	}
};
struct line{
	point a,b;
};

int across(line p,line q)
{
	point tempa=(p.b-p.a);
	point tempb=(q.b-q.a);
	if(tempa.x*tempb.y-tempb.x*tempa.y==0)
	return 0;
	else
	return 1;
}

int main()
{
	int n,i,j,k;
	line a,b;
	cin>>n;
	cout<<"INTERSECTING LINES OUTPUT"<<endl;
	while(n--)
	{
		cin>>a.a.x>>a.a.y>>a.b.x>>a.b.y>>b.a.x>>b.a.y>>b.b.x>>b.b.y;
		
		if(!across(a,b))        //平行 
		{
			double b1=a.a.y-a.a.x*((a.b.y-a.a.y)/(a.b.x-a.a.x));
			double b2=b.a.y-b.a.x*((b.b.y-b.a.y)/(b.b.x-b.a.x));
			if(b1==b2)
			cout<<"LINE"<<endl;
			else
			cout<<"NONE"<<endl;
		}
		else                  //相交 
		{
			double a1,a2,b1,b2,c1,c2,x,y;
			a1=a.b.x-a.a.x;a2=b.b.x-b.a.x;
			b1=a.a.y-a.b.y;b2=b.a.y-b.b.y;
			c1=a.a.x*a.b.y-a.a.y*a.b.x;
			c2=b.a.x*b.b.y-b.a.y*b.b.x;
			x=(c1*a2-c2*a1)/(a1*b2-a2*b1);
            y=(c1*b2-c2*b1)/(a2*b1-a1*b2);
            printf("POINT %.2lf %.2lf\n",x,y);
		}
	}
	cout<<"END OF OUTPUT"<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值