【PAT】1027. Colors in Mars (20)

题目


链接:https://www.patest.cn/contests/pat-a-practise/1027

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input
15 43 71
Sample Output
‘#123456




分析


题意:

十进制转化为十三进制




题解(已AC)


/**
    2018.2.1
    Donald
*/
//1027. Colors in Mars (20)

/**
    给出3个2位数,转化为13进制数
*/


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int Red, Green, Blue;
char red[3], green[3], blue[3];

void turnToRadix13(int Color, char color[]) {
    int temp = 0;
    int cnt = 1;
    while (Color != 0) {
        temp = Color % 13;
        Color /= 13;
        if (temp > 9) {
            color[cnt--] = temp - 10 + 'A';
        } else {
            color[cnt--] = temp + '0';
        }

    }
    if (cnt >= 0) {
        for (int i = 0; i <= cnt; ++i) {
            color[i] = '0';
        }
    }
}

int main(void) {

    scanf("%d %d %d", &Red, &Green, &Blue);

    turnToRadix13(Red, red);
    turnToRadix13(Green, green);
    turnToRadix13(Blue, blue);

    printf("#%s%s%s", red, green, blue);


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值