G - Oil Skimming(匈牙利)

Thanks to a certain “green” resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water’s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of ‘#’ represents an oily cell, and a character of ‘.’ represents a pure water cell.
Output
For each case, one line should be produced, formatted exactly as follows: “Case X: M” where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>
using namespace std;
char ma[654][654];
int map1[666][666];
int map2[666][666];
bool used[666];
int linker[666];
int n, ans;
int x[] = {0, 0, 1, -1};
int y[] = {1, -1, 0, 0};
bool dfs(int u)
{
  for(int v = 1; v < ans; v++)
  {
    if(map2[u][v]&&!used[v])
    {
       used[v] = true;
       if(linker[v]==-1||dfs(linker[v]))
       {
         linker[v] = u;
         return true;
       }
    }
  }
  return false;
}
int hungary()
{
   int res = 0;
   memset(linker, -1, sizeof(linker));
   for(int u=1;u<ans;u++)
   {
      memset(used, false, sizeof(used));
      if(dfs(u))
      res++;
   }
   return res;
}
int main()
{
   int T;
   scanf("%d", &T);
   for(int t=1;t<=T;t++)
   {
     scanf("%d", &n);
     for(int i=0;i<n;i++)
     scanf("%s", ma[i]);
     ans = 1;
     memset(map1, 0, sizeof(map1));
     memset(map2, 0, sizeof(map2));
     for(int i=0;i<n;i++)
     {
       for(int j=0;j<n;j++)
       {
         if(ma[i][j]=='#')
         map1[i][j] = ans++;
       }
     }
     for(int i=0;i<n;i++)
     {
       for(int j=0;j<n;j++)
       {
         if(map1[i][j]!=0)
         {
           for(int k=0;k<4;k++)
           {
              int a = x[k] + i;
              int b = y[k] + j;
              if(map1[a][b]!=0&&a>=0&&a<n&&b>=0&&b<n)
              {
                map2[map1[i][j]][map1[a][b]] = 1;
              }
           }
         }
       }
     }
     printf("Case %d: %d\n", t, hungary()/2);
   }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值