hdu 4764 Stone(巴什博弈)

Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc… Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

Output
For each case, print the winner’s name in a single line.

Sample Input
1 1
30 3
10 2
0 0

Sample Output
Jiang
Tang
Jiang

简单博弈!
分析题目,数目总共n个,两个人都只能拿1~k个,那么可以保证无论先手第一次拿多少,后手拿了一次之后第一轮总共拿了k+1个,只要n-1是k+1的倍数,那么先手无论如何都可以赢,反之就会输,代码如下:

#include<iostream>
using namespace std;
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        if(n==0&&k==0)
          break;
        n--;          
        k++;       //每次先手在1~k之内取任意数,后手都能保持这一轮取的数字为k+1 
        if(n%k==0)         //先手取到n-1则先手败 
          cout<<"Jiang"<<endl;
        else              //否则先手赢 
          cout<<"Tang"<<endl;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值