POJ 2752 Seek the Name, Seek the Fame(KMP)

Seek the Name, Seek the Fame
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

POJ 2752
Appoint description:
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

KMP的理解练习,发现通过练习果然可以懂好多东西,快慢慢的看破KMP了,加油(^o^)/

#include <cstdio>
#include <cstring>
#define M 400050
#define N 1000010

char ptr[M];
int next[M], plen, num;

void getnext()
{
    int i = 0, k = -1;
    next[0] = -1;
    while(i < plen)
    {
        if(k == -1 || ptr[i] == ptr[k])
        {
            i++, k++;
            next[i] = k;//这里貌似不能再简化了,不如会出事,因为这里不是让它与主串对比,而是与自己对比,把自己看成主串,与自己对比失败的前面一段看成模板串,因为模板串的next肯定是已知的,再对比,一直循环下去
        }
        else
        {
            k = next[k];
        }
    }
}
void kmp()
{
    char ostr = ptr[plen-1];
    int k = next[plen-1], al[M];
    num = 0;
    al[num++] = plen;
    while(k != -1)
    {
        if(ptr[k] == ostr)//配对成功才能记录,否则表示模式串的最后一个与主串的最后一个是不匹配的。要明白模式串一直是前缀
        {
            al[num++] = k + 1;
        }
        k = next[k];
    }
    for(int i=num-1; i>=0; i--)
    {
        printf("%d", al[i]);
        if(!i)
            printf("\n");
        else
            printf(" ");

    }


}
int main()
{
    while(scanf("%s", ptr) != EOF)
    {
        plen = strlen(ptr);
        getnext();
        kmp();
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值