HDU 1398 (母函数)

Square Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11363 Accepted Submission(s): 7783

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, …, and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input
2
10
30
0

Sample Output
1
4
27

题意:对于 1^2 , 2^2, 3^2, 4^2, ….., 17^2, 输入一个数 n, 求 n 的组合数
题解:用母函数的方法,至于母函数是什么,这个还是看百度或者课件什么的

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 400

int num2[M], num[M];
void getnum()//打表
{
    int flag[18];
    for(int i=0; i<18; i++)
        flag[i] = i * i;
    for(int i=0; i<M; i++)
    {
        num[i] = 1;
        num2[i] = 0;
    }
    for(int i=2; i<18; i++)//对于每一个 n ,都可能由 i^2 组成
    {
        for(int j=0; j<M; j++)//枚举每一个数
        {
            for(int k=0; k+j<M; k+=flag[i])//跳转的距离是flag[i] 
            {
                num2[k+j] += num[j];//加上的数值是每一个跳转距离的那个数 
            }
        }
        for(int j=0; j<M; j++)
        {
            num[j] = num2[j];//更新每一个数值 
            num2[j] = 0;
        }
    }
}

int main()
{
    int n;
    getnum();
    while(scanf("%d", &n) && n)
    {
        printf("%d\n", num[n]);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值