POJ_2309_BST

BST
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10114 Accepted: 6143

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2 31 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

POJ Monthly,Minkerui

题意:给出一个类似二叉搜索树的结构,给出一个数让你求以它为根的树的左右下限为多少。

这个题目需要有一定的脑洞,因为这个题目需要联系到二进制,没有一点奇怪的姿势是破不了的。那么请大家看下图


你会发现以n为根的子树的左下限就是把n的二进制值的最后一位1移动到最后一位,右下限就是把n的最后一位1到最后一位之间全部替换成1.

那么现在就简单了首先就是求出最后一个1所在的位置  k = (n & -n);

然后左下限为 n-k+1;右下限为n+k-1;

代码如下

#include <cstdio>
#include <math.h>
using namespace std;
int main(){
    int T,n;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        int k=n&(-n);
        printf("%d %d\n",n-k+1,n+k-1);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值