akoj-1076-Encoding

Encoding

Time Limit:1000MS  Memory Limit:65536K
Total Submit:62 Accepted:35

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string. 

2. If the length of the sub-string is 1, '1' should be ignored. 

Input

The first line contains an integer N (1 < = N < = 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

Source

#include <stdio.h>
#include <string.h>
#define MAXN 10000 + 10

char str[MAXN];

int main()
{

	int n, i, k, c, thisn, maxn;
	scanf("%d", &n);
	while (n--)
	{
		c = 0;
		scanf("%s", str);
		k = strlen(str);
		str[k] = -1; // 这里的输入长度小于定义的长度所以不会越界 
		thisn = maxn = 0;
		for ( i=0; i<k; i++ ) {
			thisn++;
			if ( thisn > maxn ) {    //实时更新段的长度 
				maxn = thisn;
			}
			if ( str[i+1] != str[i] ) { // 当后面的与前面的不同时输出之前的 
				thisn = 0;
				if ( maxn == 1 ) {
					printf("%c", str[i]);
				}
				else {
					printf("%d%c", maxn, str[i]);
					maxn = 0; // 输出后将最大长度再次赋值为0 
				}
			}
		}
		
		printf("\n");
	}
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值