Uva 10881 - Piotr's Ants

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n  (0 <=   n  <= 10000) . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
const int MAXN = 10010;
int L, T, n;
struct node{
   int l; 
   bool fx; //true为右 
   int id; 
}MaYi[MAXN];
bool cmp(node a, node b)
{
 	 return a.l<b.l;
}
int xb[MAXN];//找到现在的下标 
map<int,int>shumu;
int main()
{
   int t, cs, i, j;
    int l;
    char c;
    scanf("%d",&t);
    //freopen("d:\out.txt","w",stdout);
    for(cs=1; cs<=t; cs++)
    { 
	      scanf("%d%d%d",&L,&T,&n);
	      for(i=0; i<n; i++)
	      {
               scanf("%d %c",&l,&c);
               MaYi[i].l=l;
               if(c=='R')
                    MaYi[i].fx = true;
               else
                    MaYi[i].fx = false;   
			   MaYi[i].id = i;    
	      }
	      sort(MaYi,MaYi+n,cmp);
	      shumu.clear();
	      //确定原来位置,以及统计现在相对位置 ,再移动蚂蚁 统计每个点的蚂蚁数目 
	      int s = 0;
	      for(i=0; i<n; i++)
	      {
  		   	   xb[MaYi[i].id] = i;
  		   	   //向右 
  		   	   if(MaYi[i].fx)
  		   	   {
					MaYi[i].l += T;
			   }else{
					MaYi[i].l -= T;
               }
               shumu[MaYi[i].l]++;
	   	  }
		  sort(MaYi,MaYi+n,cmp);
		   
    
	      printf("Case #%d:\n",cs);
	      for(i=0; i<n; i++)
	      {
                int a = xb[i];  
            
                int d = MaYi[a].l;
                if(MaYi[a].fx) 
                {
                    if(d>=0 && d<=L)
                    {
                        if(shumu[d]==1)
                        {
                            printf("%d R\n",d);
                        }else{
                            printf("%d Turning\n",d);
                        }
                    }else{
                        printf("Fell off\n");
                    }
                }else{
                    if(d>=0 && d<=L)
                    {
                        if(shumu[d]==1)
                        {
                            printf("%d L\n",d);
                        }else{
                            printf("%d Turning\n",d);
                        }
                    }else{
                        printf("Fell off\n");
                    }
                }
               
          } printf("\n");
    } 
    return 0;
}



Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值