sdut 1500 Message Flood

Message Flood

Time Limit: 1500ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3

来源

第9届中山大学程序设计竞赛预选赛
  • 提交
  • 状态
  • 讨论
    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdlib>
    #include <cstdio>
    #include <queue>
    #include <stack>
    #include <cmath>
    #include <map>
    
    using namespace std;
    
    struct node
    {
        int flag;
        struct node *next[26];
    };
    
    struct node *creat()
    {
        int i;
        struct node *p;
        p=(struct node *)malloc(sizeof(struct node ));
        for(i=0;i<26;i++)
        {
            p->next[i]=NULL;
        }
        p->flag=0;
        return p;
    }
    
    void Insert(struct node *p,char *s)
    {
        int i,len,ans;
        len=strlen(s);
        for(i=0;i<len;i++)
        {
            if(s[i]>='A' && s[i]<='Z')
                ans=s[i]-'A';
            else
                ans=s[i]-'a';
            if(p->next[ans]==NULL)
                p->next[ans]=creat();
            p=p->next[ans];
        }
        p->flag=1;
    }
    
    int finds(struct node *p,char *s )
    {
        int i,len,ans;
        len=strlen(s);
        for(i=0;i<len;i++)
        {
            if(s[i]>='A' &&s[i]<='Z')
                ans=s[i]-'A';
            else
                ans=s[i]-'a';
            if(p->next[ans]==NULL)
                return 0;
            p=p->next[ans];
        }
        if(p->flag==1)
        {
            p->flag=0;
            return 1;
        }
        return 0;
    }
    
    void Delete(struct node *p)
    {
        int i;
        for(i=0;i<26;i++)
        {
            if(p->next[i]!=NULL)
            {
                Delete(p->next[i]);
            }
        }
        free(p);
    }
    
    int main()
    {
        int n,m,i,num;
        char s[20000][100],s1[100];
        struct node *tree;
    
        while(~scanf("%d %d",&n,&m),n)
        {
            num=0;
            tree=creat();
            for(i=0;i<n;i++)
            {
                scanf("%s",&s[i]);
            }
            for(i=0;i<m;i++)
            {
                scanf("%s",s1);
                Insert(tree,s1);
            }
            for(i=0;i<n;i++)
            {
                num+=finds(tree,s[i]);
            }
            printf("%d\n",n-num);
            Delete(tree);
        }
        return 0;
    }
     
    
    
    
    /**************************************
    	Problem id	: SDUT OJ 1500 
    	User name	: mxjr130326刘继国 
    	Result		: Accepted 
    	Take Memory	: 28992K 
    	Take Time	: 50MS 
    	Submit Time	: 2014-06-28 21:00:03  
    **************************************/
    题目大意:给n个字符串,然后又给出m个字符串,问前n个字符串有多少个没有在m个串中出现。每个字符串长度不超过10,不区分字母大小写。

    数据量很大,简单模拟肯定不行,很显然要用Trie树。。

    最后一个Delete函数,主要是为了释放空间, 不过时间耗时非常大。时间:500ms , 空间消耗1W+

    去掉Delete函数,时间:250ms,空间消耗:5w+


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值