poj 1252 Euro Efficiency(多次完全背包)

Euro Efficiency
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1866 Accepted: 848

Description

On January 1st 2002, The Netherlands, and several other European countries abandoned their national currency in favour of the Euro. This changed the ease of paying, and not just internationally. 
A student buying a 68 guilder book before January 1st could pay for the book with one 50 guilder banknote and two 10 guilder banknotes, receiving two guilders in change. In short:50+10+10-1-1=68. Other ways of paying were: 50+25-5-1-1, or 100-25-5-1-1.Either way, there are always 5 units (banknotes or coins) involved in the payment process, and it 
could not be done with less than 5 units. 
Buying a 68 Euro book is easier these days: 50+20-2 = 68, so only 3 units are involved.This is no coincidence; in many other cases paying with euros is more efficient than paying with guilders. On average the Euro is more efficient. This has nothing to do, of course, with the value of the Euro, but with the units chosen. The units for guilders used to be: 1, 2.5, 5, 10, 25, 50,whereas the units for the Euro are: 1, 2, 5, 10, 20, 50. 
For this problem we restrict ourselves to amounts up to 100 cents. The Euro has coins with values 1, 2, 5, 10, 20, 50 eurocents. In paying an arbitrary amount in the range [1, 100] eurocents, on average 2.96 coins are involved, either as payment or as change. The Euro series is not optimal in this sense. With coins 1, 24, 34, 39, 46, 50 an amount of 68 cents can be paid using two coins.The average number of coins involved in paying an amount in the range [1, 100] is 2.52. 
Calculations with the latter series are more complex, however. That is, mental calculations.These calculations could easily be programmed in any mobile phone, which nearly everybody carries around nowadays. Preparing for the future, a committee of the European Central Bank is studying the efficiency of series of coins, to find the most efficient series for amounts up to 100 eurocents. They need your help. 
Write a program that, given a series of coins, calculates the average and maximum number of coins needed to pay any amount up to and including 100 cents. You may assume that both parties involved have sufficient numbers of any coin at their disposal. 

Input

The first line of the input contains the number of test cases. Each test case is described by 6 different positive integers on a single line: the values of the coins, in ascending order. The first number is always 1. The last number is less than 100. 

Output

For each test case the output is a single line containing first the average and then the maximum number of coins involved in paying an amount in the range [1, 100]. These values are separated by a space. As in the example, the average should always contain two digits behind the decimal point. The maximum is always an integer. 

Sample Input

3
1 2 5 10 20 50
1 24 34 39 46 50
1 2 3 7 19 72

Sample Output

2.96 5
2.52 3
2.80 4

Source

题目:http://poj.org/problem?id=1252

分析:这题应该很好想到用背包来做,但是一做完就wa了,最近这种思维漏洞越来越多。。。= =,本来以为正反两次完全背包就行(正的为付钱,反的为找钱),后来才发现可能多次付钱找钱,其实不是多次付钱找钱,只是之前的状态本该找钱的,结果付钱了,反正就是要写个多次搞,然后就是钱可以加到超过100了,于是wawawa,终于A掉了

代码:

#include<cstdio>
#include<iostream>
using namespace std;
const int mm=11111;
int f[mm],a[6];
int i,j,t,sum,ans,n;
bool flag;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        for(n=i=0;i<6;++i)scanf("%d",&a[i]),n=max(n,a[i]);
        n=max((100-n+1)*n,100);
        for(i=0;i<n;++i)f[i]=mm;
        ans=sum=f[0]=0;
        flag=1;
        while(flag)
        {
            flag=0;
            for(i=0;i<6;++i)
                for(j=a[i];j<=n;++j)
                    if(f[j]>f[j-a[i]]+1)f[j]=f[j-a[i]]+1,flag=1;
            for(i=0;i<6;++i)
                for(j=n-a[i];j>0;--j)
                    if(f[j]>f[j+a[i]]+1)f[j]=f[j+a[i]]+1,flag=1;
        }
        for(i=1;i<101;++i)sum+=f[i],ans=max(ans,f[i]);
        printf("%.2lf %d\n",sum/100.0,ans);
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值