hdu 3496 Watch The Movie(二维背包)

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1822    Accepted Submission(s): 610


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input
  
  
1 3 2 10 11 100 1 2 9 1
 

Sample Output
  
  
3
 

Source
 

Recommend
zhouzeyong
 
分析:这题其实只是一个普通的二维背包,一维要求刚好装满,一维只限制上限,然后我们可以全部用刚好装满的方法来做,最后枚举那维有上限的来取最值就行
代码:
import java.io.*;
import java.util.*;
public class Main
{
	public static int max(int a,int b)
	{
		return a>b?a:b;
	}
	public static void main(String arg[])
	{
		Scanner cin=new Scanner(System.in);
		int oo=-1000000000;
		int mm=1111;
		int mn=111;
		int f[][]=new int[mn][mm],t[]=new int[mn],v[]=new int[mn];
		int i,j,k,n,m,l,T;
		T=cin.nextInt();
		while(T-->0)
		{
			n=cin.nextInt();
			m=cin.nextInt();
			l=cin.nextInt();
			for(i=0;i<n;++i)
			{
				t[i]=cin.nextInt();
				v[i]=cin.nextInt();
			}
			for(i=0;i<=m;++i)
				for(j=0;j<=l;++j)f[i][j]=oo;
			f[0][0]=f[m][l]=0;
			for(i=0;i<n;++i)
				for(j=m;j>0;--j)
					for(k=t[i];k<=l;++k)
						f[j][k]=max(f[j][k],f[j-1][k-t[i]]+v[i]);
			for(i=0;i<l;++i)f[m][l]=max(f[m][l],f[m][i]);
			System.out.println(f[m][l]);
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值